Timer Widget working Backwards

I am running a NodeMcu with my app on an apple device so I cannot use Eventor. I am using a timer widget to turn on and off a single relay. I understand you do not need to run any code to do this as I am pushing a simple 1 or 0 (just like using a button widget where I could just flip my 1 and 0)

I have been racking my mind for days as I at first attached this to and extensive code that monitors my heat system.
For diagnostic purposes
-I tossed that code and tried running the relay on its own MCU. It does react but everything is backwards. (Off is on and On is off).
-Using a push button does allow me to switch 1/0 with proper results

-My question is, is the Timer widget, exactly the same as the button widget in flipping the 1 and 0 in the app. It does not fix my backwards problem when doing this, I have tried running on D1, D2, D4 and no luck reversing the power

this is my relay


Yes, that should work by sending a 0 for ON and a 1 for OFF, assuming your relay is active LOW

Just means you have a popular active LOW relay.

Thank you for quick response. I just tried 3 different ones; and flip flopping my 1/0 0/1 and start stop are still flipped

So I tried something else. I pulled off the relay so i just have the mcu. When working with just the onboard blue LED I get the same response. Start time= light off and Stop time= light on (even when flipping 1/0 0/1 on the widget) . When doing this with a button widget it works fine still. Any ideas?

On board LED is active LOW too.

But if the timer widget works the same as a button widget. Why can I get the button widget to respond how i want it by flipping 1/0 with the LED. but not the timer?

Update: I assigned V pins with button and have it working. I still don’t understand why D pins would not let me flip them. But hey it works


When you were using digital pins were you mixing gpio numbers will still screened reference numbers?