The arduino is connected (to WiFi) but my smartphone show "device is offline"

Hi friends

I have the following problem with this configuration:
Arduino uno
ESP8266 SP1
3.3 V regulator

Serial monitor show this when run the Serial Moonitor

but my smartphone show “device is offline”

The wifi Security Type WAP2-Personal

All AT comands run perfectly

SDK is : ESP8266_NONOS_SDK_V1.5.3_16_04_18

I´ll apreciate your help.


That shows that the ESP is connected to your WiFi, but not if the Arduino is connected (through the ESP/WiFi link) to the Blynk Server… that is why the app shows offline, because you device is not connected (to server).

Has it worked before, if so, have you changed something recently? Double check your pin connections between ESP and Arduino and confirm proper Auth code, etc.

I am not very familiar with ESP… but 1.0.0/0 (Apr 16 2006) does sound like an old firmware version?

Hi Thanks for your response. yes I changed the internet provider, upgraded Blynk.
I fire the ESP8266 with all firmware

I read in blynk about the port 8442

and I checked with a aplication in the web the port 8442-

but when I run the blynk bat …

Is the port is OK??? is open? the problem is the firmware on ESP8266??

Thanks for your response.

Looks like the port is blocked.

Hi, I included a exception in the firewall for arduino… the problem is the router??

Why are you running the USB link?? You have WiFi… USB COM port and Network port, two totaly different types of “ports” :wink:

USB-link is a temporary (says the guy using it for months) method of linking an Arduino (that does NOT have WiFi or Ethernet options) to the internet/network and thus to a Blynk server. Don’t use it in your case (unless your ESP is broken).

As for the WiFi connection, you shouldn’t “normally” have to worry about port blocking or forwarding if your device is inside your network, initiating the port connection… and port forwarding generally becomes an issue only when you have your phone out on the town and want to check in in on your IoT stuff, located in your home network and local server.

I do see another possible issue, you are using a 3.3v ESP on a 5v Arduino… I see you have a 3.3v regulator for the power, however the TX from the Arduino back to the RX on the ESP will still be at 5v potential, so if you haven’t already damaged it, you will soon. You need some form of 5v to 3.3v level shifter for that line.

Hi I´m using ESP-01 adapter to power the ESP. I used configuration (ESP+adapter+arduino), time ago with other Blynk version and other internet supplier; for rthis reason I think in the ports…

I´m confused with the blynk-ser.bat . I thought I could see if I connected. My internet provider does not give me the router username and password.

I test with three different arduinos and two ESPs … and give me the same errors.

I apreciate your help

You CAN try that USB-link (NO shield) method… just don’t use any of the ESP libraries or connections in that case. This will at least confirm if your router or ISP is blocking network port 8442.

1 Like

USB-link work fine…!!! the port is ok…!!! thanks

I don´t understand the ESP8266 working with all AT commands,
Now send me this mesage

by one seconds the smartphone is conected… and then lose the conection …

I had a similar problem with nano via software serial. The solution was to downgrade the blink lib version to 0.4.0. There is a topic from the last days about it.

1 Like

HI thanks for your coments, I don´t know if look for other SDK or change the blynk version…

If you could connect via USB link, the issue probably rests in the connection between the Arduino and ESP… That generally seems the weak point in these device mashups.

Whether or not that is due to the software serial or not is yet to be determined… but software serial is an Arduino library not directly Blynk related, thus not sure how Blynk library version would affect it.

Revert your sketch back to the ESP settings (if you haven’t already) and post your code here for us to double check it. Thanks.

1 Like

Hi Artillero, I controling the conection with AT comands from arduino serial monitor, and all comandas are ok response .
The last SDK flashing was

AT version: 14 2016 18:54:01)
SDK version:2.0.0(656edbf)
compile time:Jul 19 2016 18:44:44

With this version and use code
Only change de Token SSDI and PSW

the response in the monitor serie is:

Blynk (LOGO)
v0.4.6 on Arduino Uno

[603] Connecting to CoopenetULTRA-4321303
[13624] AT vdrsion:1.3.0/0(Jul 14 2016 18:54:01(
SDK version:2.0.0(656dd9
[19703] +CIFSR:ST@IP,“”

[19715] Connected to WiFi
[30392] Ready (ping: 12ms).
[40415] Login timeout

Blynk in the Smartphone shows connected and instantly drops the connection…

I think the connection between Arduino and ESP is OK there must be an incompatibility between SDK versions … ARDUINO…Blynk…

More likely stiil an issue with your firmware and/or connection… check here

1 Like

Hi Yes, I´m using this connection.

3.3 volt adapter ESP-01 Adapter V1.0
Arduino RESET = GND
I´m flashing the ESP with this connection

When I run the the Code example “Blynk> boards_Wifi> ESP8266_Shield” change the following connection
D2 Ard = TX ESP
D3 Ard = RX ESP
GPIO = disconnected
Arduino RESET = disconnected

I test with two ESP and with three different arduinos…
The next step is burn my head …hehe… No, I plan to uninstall Arduino, Blynk and start again.

I don’t know what example you are using,but I rarely see GPIO in reference to a pin on an Arduino board? But that may just be me and my limited device availability :wink:

Have you tried the examples from the Sketch Builder (at the top right of this page)?

1 Like

yes!! I´m Running this is the example
I change the code in this part

// Hardware Serial on Mega, Leonardo, Micro...
// #define EspSerial Serial1    (include //) 

// or Software Serial on Uno, Nano...
 "#" include SoftwareSerial.h   (delete //)
SoftwareSerial EspSerial(2, 3); // RX, TX   (delete //)

I´m connected the GPIO to GND when load the firmware in the ESP. GPIO from ESP.

Well, since the ongoing issue you are running into is not uncommon, and really only involves the ESP and Arduino interconnect, have you tried asking about other solutions over at an ESP forum?

Once you have a solid, seamless, interface between the Arduino and the WiFi (internet) via the ESP, then moving forward with Blynk should be relatively easy.

This is one reason why most Blynkers use the All-in-one ESP Dev boards (Wemos, NodeMCU, etc), so they don’t have to worry about multi-MCU/device interconnect issues… they are a pain :unamused:

1 Like

I had a similar issue where my devices were powered and seemed to function correctly, but on the BLYNK app they would not show up as ONLINE. I refreshed the AUTH TOKEN, and reloaded the program with the new AUTH TOKEN and now it shows up as ONLINE.

1 Like

Hi Friends
I was able to solve the problem. Delete Arduino software, Blynk and install the version Arduino 1.8.2 ; Blynk V0.3.3 and refreshed the AUTH TOKEN…
Run AT commands AT+UART_DEF=9600,8,1,0,0
Load the example ESP8266_Shield_Softser.

Now is working perfect !!!

Thanks !!!