Terminal Widget on Android not receiving data (actually wrong default text colour)


I am trying to use the Terminal in a project but with no success.

In Arduino I have:
WidgetTerminal AlarmTerminal(V41);
AlarmTerminal.println(“Motion Detector in Hall”);

But I see nothing in Android yet when I go to the HTTP API with a GET on V41 I see: [“Motion Detector in Hall”] and I can see the updates being sent in the Serial Monitor. When I tried to change it to something else it won’t show the update on the API. I also tried http://blynk-cloud.com/keyadsfasdf/update/V41?value=test1 but this doesn’t appear to get accepted either? I also tried a different pin and made sure I only sent one update in 10 seconds to avoid any flooding.

Android Blynk Version 2.17.0, Arduino 0.4.10. The rest of the project appears to be functioning as desired.

Any ideas?

Best regards,

I appear to have worked this out. The default font colour on the terminal widget on my Galaxy S7 is Black on Black! :slight_smile:

Also it appears that you can’t pull the Terminal data from the HTTP API, or am I missing something there?

That happened in a relatively recent (a month or two ago) App update wherein the terminal colour now defaults to Black instead of Blue, if I recall correctly… Had me scratching my head for awhile when using terminal on NodeJS.

Anyhow, this is the 2nd time I have seen it in the forums… so I think the App Terminal Widgets default Black on Black needs to be addressed @BlynkAndroidDev & @Eugene is this for you two?

Are you referring to the user input of data into the Widget??

Ah, If I go http://blynk-cloud.com/246465b73582465d9dd771238exxxxxxxxxxxxxxxx/update/V1?value=10 It will send the user input to the terminal.

If I go http://blynk-cloud.com/246465b73582465d9dd7712xxxxxxxxxxxx/get/V1 I do not appear to get the last user input?

I would also like to be able to get the history of the terminal (the last 25 as per cloud) from the API if that is possible?

The default font color in Terminal widget should be white (on black backgtound).

1 Like

I agree… but it is Black on Black, at least on Android. v2.17.1 with Dark theme. Other themes seem OK at a quick glance.

Can we get this one logged as a bug and this ticket marked as resolved?

@BlynkAndroidDev It is an App GUI issue, and may already have been fixed in upcoming release? So I am not sure if creating a ticket on Library’s GitHub is correct, or just posting here?