Stuck on connected to wifi

i am using arduino uno and esp8266 via software serial and i am using the basic wifi shield sketch to connect but nothing happens after it shows connected to wifi and in the app it shows offline. Please help.

And search this forum for the multitude of similar issues and solutions :stuck_out_tongue_winking_eye:

have been searching all day …but still no luck.

Actually in my case it gets connected to the wifi and just stays there.

I searched for a few seconds… lots of topics with results :wink: … try clicking on that “search” link I already provided.

Yep, normal… now confirm App is online, same AUTH code in App project as in sketch, confirm your App is connected to the same Server & IP (if you are using Local Server), etc, etc…

Auth code is same but on my blynk app it shows device to be offline

Well, you haven’t done enough reading yet :wink: as you haven’t noticed that we don’t all jump in and start handholding when someone effectively says nothing more than “My Blynk thingy is not working, Help.”

You are mentioning a basic Blynk 101 conection issue and this forum is full of same questions… and repeated answers

But lets start again… You haven’t provided many details, posted your (properly formatted) sketch, confirmed type of server, phone, versions, relevant App settings, etc, etc. So do all that and perhaps someone will have something more to go on.

Help us to help you :stuck_out_tongue_winking_eye:

//#define BLYNK_DEBUG
#define BLYNK_PRINT Serial                      
#include <ESP8266_Lib.h>
#include <Servo.h>                              // include the Servo library
#include <BlynkSimpleShieldEsp8266.h>   // include Blynk ESP8266
#include <SoftwareSerial.h>                     

SoftwareSerial EspSerial(10,11); // RX, TX
// Set ESP8266 Serial object
//#define EspSerial Serial1                        
Servo Motor;                                    // create the servo objects

ESP8266 wifi(&EspSerial);

// You should get Auth Token in the Blynk App.
// Go to the Project Settings (nut icon).
char auth[] = "MyAuthToken";
char ssid[]="ssid";
char pass[]="";
void setup()
  // Set console baud rate
  // Set ESP8266 baud rate

  Blynk.begin(auth,  wifi, ssid, pass);  // Wifi connection
  Motor.attach(10);                                           // attaches the servo on pin 13 to a servo object
  Motor.write(90);                                            // 90 is neutral, so neither of the servos should turn


void loop()

when i press the play button on my phone app it shows device offline and when i check serial output it shows this:

 ___  __          __
   / _ )/ /_ _____  / /__
  / _  / / // / _ \/  '_/
 /____/_/\_, /_//_/_/\_\
        /___/ v0.5.0 on Arduino Uno

[608] Connecting to Warhead
[3826] AT version: 24 2017 12:03:18)
SDK version:2.1.0(ace2d95)
compile time:Oct 24 2017 15:48:02
Bin version(Wroom 02):1.5.1
[9292] +CIFSR:STAIP,""
[9300] Connected to WiFi

it stays on connected to wifi.

Very odd IP address and MAC

What type of router is this device connecting to via WiFi… does that router have internet access?

I think you have a networking issue, not a Blynk issue.

Very odd comment! :stuck_out_tongue_winking_eye:

Why is it odd?.. it is not your typical internal IP handed out by a typical router… so if the OP is using some unique way of connecting the UNO/ESP to, supposedly, the internet, then it may not be connecting properly to the Cloud Server and thus to his App (which while the OP hasn’t given any details there… one must assume it is actually connecting to the Cloud Server or it wouldn’t even log in).

Anyhow, back to my movie :stuck_out_tongue_winking_eye:

I think it is your public IP
are you sure to have DHCP active on your router ?

I thought you meant that there was something wrong with the number itself :slight_smile: But there are some untypical routers and ISP’s that lets you have multiple public IP’s. But that’s probably not the case here so I let you sort it out. You know how much I like general network errors :yum:

Any recommendations? :wink:

Not the same IP for the country the OP is logged into this forum from.

Hardcore Henry, from around 2016. Entire movie is from the 1st person point of view of a resurrected cyborg… lots of guns, grenades, loud music and knockers.

Oh no you don’t… I think I already lost my patience with this one :stuck_out_tongue_winking_eye:

There’s just to many unknowns, could be anything and probably none are Blynk related. :neutral_face:

1 Like

okey Gunner , but can’t never be a local IP.
I hope Pulkitnarwani didn’t forget to replace “ssid” with the real one !

Obviously i replaced it with my ssid :joy:

I changed my network and get a normal IP and mac but still the same problem…stuck at connected to wifi

Remove # from the first line of your sketch and paste what you see in Serial Monitor.