Strange problem with zergba widgets

Strange problem with zeRGBa widgets.
Android app version 2.20.3 and node-red library 0.6.0 with Blynk cloud server
Two zeRGBa widgets in merge mode on V1 and V2.

With the app open on the smarthone sets V1 on 255 0 0 “red” and V2 on 0 255 0 “green” from node-red, all OK
Now, if I go out and come back in the app the V1 widget keeps the color red, while the second zeRGBa the V2 has a color that has nothing to do with it, certainly not green!
If i send a “syncvirtual” command on pin V2 server send me the correct green color 0 255 0, but in any case the color is wrong on the app side.

I do not think it’s a problem with the nodered library, but I did not try the arduino library.
Does anyone use two zeRGBa widgets in the same app have same problem?

Best regards

I am using the latest local server (Java 8) and up to date server and App. While putting in one zeRGBa on the screen worked a treat, I’m having terrible problems with the second zeRGBa. I’m using again new version of node-red-contrib-blynk-ws with the new zeRGBa node. With one zeRGBa all is well. If I close the app and reopen, things are as they should be.

(Raspberry Pi 3, but Blynk knows nothing about that, dealing only with MQTT all of which is well tested) The second zeRGBa loses the colour of my RGB LEDs even though this remains correct on the actual LEDs… e.g. with second zeRGBa set to RED=255, LED is RED, with phone off then on or switch apps then back, second zeRGBa now shows a dim mix of colours. Wrong. LED remains RED. Now manually alter the zeRGBa to white, LED remains RED then the Blynk server seems to wait or maybe reset and then the LED beomes WHITE trhen the 2nd zeRGBA goes back to that dim mix of colours… LED remains white. Another time, that last step, moved APP to RED, LED went to RED, ok. Meanwhile first zeRGBa stays ok on RED. Using merge mode, virtual pins 25 and 26.

No doubt about it, second zeRGBa is in trouble.

Do either of you have some form of code that can show a repeatable issue?

Reason I ask is that I have tested a non Node-Red sketch with two, then three, zeRGBa widgets (all in merge mode), one on a tab with a bunch of other widgets, and the other two together on their own tab. I can set each one to its own individual settings, with their values forwarded to physical RGB LED and display widgets showing HEX code and color of the of each’s colour properties… And everything stays as set (on each zeRGBa and their respective LED & Display Widgets) even after exiting or shutting down the App.

So it just might be a Node-Red related issue? I have never used Node-Red, so am unable to test.

Node-red - two zeRGBAs - quite repeatable. I can select a colour (the zergbas are talking to simple virtual pins - the output from the zeRGBA is then processed to control actual leds. Both accept a colour setting and the output is correct. Swichs apps then back to blynk and the first zergba in app remains the correct colour, the second zergba swiches to a half-lit greeny blue. In both cases the actual outputs remain as they were… but the app thinks the second zergba has changed to this new colour. This happens reliably.

I’m using the local server, all of this installed this week.

As the actual output remains correct and can be seen on the node red zergba node, it seems that after hiding the Android app and bringing it back up, it is where the problem lies as it thinks the colour of tyhe seocnd zergba has changed, either that or the local server is giving it bad info?

If you are using Android app, I could create a logging build to log input/output of RGB widget, so we could check is it app’s side issue or something else.

yes please…


Remember, this only happens on the second of two zergbas on a page.

Sounds like it resets to the default pointer location (basicly parks in the middle).

Very strange… even after both this morning’s Phone update to 8.0 and App update to 2.21.0 all my zeRGBa widgets are still parked where I put them after my last post. But as stated, I don’t use Node-Red, so possibly the reason.

I have just now updated from app 2.20.3 to 2.21 and no difference. On the phone make the App go away and bring it back to the foreground and once again the second zergba on the Android phone goes to that “parking position” without affecting the PC. The first zergba remains correct.

Indeed, it seems that when the app reconnects to the local blynk server, that’s when the second zergba on the app goes wrong?

I also could not reproduce this issue. Ok, after next release, that should be very soon, I’ll create a logging build.

I’ve narrowed down the issue with a second zeRGBa on a page defaulting to the middle (when the program loses focus/Android phone put on standby) down to the local server. I’ve switched back to your Blynk server and the problem went away. I made no other changes. The local Blynk server is the problem (latest version no more than 2 days ago).

This problem with the second zeRGBa occurred reliably, every time with the local server and has gone away using your server.

(the problem with the segmented switch not working was my fault. Still cant copy/paste that correctly but I think that might be Node Red?)

What exactly local server version do you have?

I’ve removed the version number sorry. Downloaded from your site 21/05/2018 - Java 8 compatible and running on an up to date Raspberry Pi 3B+

For clarity of troubleshooting… you are still using Node-Red with this test? I don’t, but I do use Local Server and still no issues with 2nd, 3rd, etc. zeRGBa.

Yes, Node Red and node-red-contrib-blynk-ws

1 Like