Step selection in Numeric input constrained by Min/Max values

Hello,

I have a temperature setting I like to constrain to 100-450 but like to use the steps in the Numeric input widget to increment by a value of 5.

It appears the step value is being constrained buy the minimum and maximum values of the datastream
What this means is the lowest I can set the step value to is 100. Unless I change the datastream minimum value lower, then it corresponds.

Is this intentional? Worked good on version 1

Any way to work around this other than at the hardware side?

Thanks

Which is exactly the behaviour you’ve said you want to achieve because if you constrain the value to a lower limit of 100 then stepping below that would go below that lower limit.

Yes, it’s an intentional feature of Blynk IoT

I’m not sure what behaviour it is you want to work around, as I explained above, if you set constraints on min/max then you shouldn’t be able to exceed these in either direction. Maybe you need to add some further clarification to your question.

Pete.

Pete, Thanks for the reply.

Sorry, I realize my post was not worded the best.

The actual step setting is what is also being constrained. Not only the datastream value.

The intent is not to increment below 100. the intent is to increment in a step value of 5, within the constrained limit.

As you may know the Numeric wiget input has a + and - input surrounding the set datastream value. pressing on these inputs increments the datastream value according to the step value setting.

What I am wanting is to press the + and have the value increment accordingly 100, 105, 110, 115 and so on. But right now I am stuck with 100, 200, 300, 400, 450

This worked flawlessly with blynk1 constraining the virtual pin, but having full control of the step value.

Thank you,

Archy.

Some screenshots of your widget setup, datastream setup, and a CLEAR description of what happens when you press the + and - buttons on the step widget would probably help, as I currently don’t think I fully understand the issue.

Pete.

Pete, again thanks for the help, included are photos as requested. I hope this clears things up.

One might ask, why the desire to constrain the min to 100? Why not 5? I would say that the settings of a refrigerator would have the same requirement. You would want to constrain the refrigerator above a freezing point, but increment the set point in values less than 32.

Looks like I am only allowed to embed one picture at a time.

Not really, because you haven’t included…

I also have to say that this comment makes no sense to me…

Pete.

Sorry, referring to temperature in Fahrenheit. It’s not important to my needs, I was giving an example of use from another perspective as to why the step value should be unrestricted.

But the issue is that I have absolutely no o idea what you’re talking about.

I have questions about your scenario 1 & 2 comments, but as these are screenshots rather than text I can’t quote tge sectiins I have questions about.

Maybe you should start at the beginning, explaining everything in a single post, with screenshots where appropriate and explaining in a very clear way exactly what the issue is.

Pete.

Okay, starting over.

I would like to, set the step value in the wiget to 5, but cannot.
included is a picture showing so

I have found that the problem is that, the step value is being constrained by the datastream constraint. I believe it should not be as with blynk 1.

example photos show the datastream constraint set to a minimum of 5 and the corresponding adjusted step value.

That’s right. You can use the step H widget instead as a workaround.

Thanks John,

I just had a look, the Step H does the same thing. When I enter a smaller value, it rejects it and fills in 100.

I like the Idea of the numeric input for the sake of having two input options.

Wow, that was hard work!

It seems like it’s a bug in the Android version of the numeric input widget.
It woks fine in iOS…

image

image

This datastream is set to a min of -10 and max of 100. I can set the step value to 5 without any issue, and it works as expected. The minimum and maximum values you can get to using the + and - buttons are constrained by the datastream.

What version of the Blynk Android app are you using?

@BlynkAndroidDev one for you to look at?

Pete.



The step H widget works fine for me.

I sense a little sarcasm here, if so, I apologize for my messy way of conveying my issue.

is this a typo? if it is indeed -10 (negetive 10) it does not prove that it works, try setting the data stream min to 20 to see if it still works. I find that I need to close edit mode and reenter for the changes to take place in the app.

Version 1.7.1

Thanks,

Strange, Thanks for this.

Archy

No.

I don’t understand why you’d say this.
It proves that you can set a step value, and that the steps increment by that amount and are constrained by the min/max values of the datastream.
Isn’t that what you want?

Pete.