SSL error on raspberry pi 3 B+

I have a raspberry PI 3 B+ and want to connect it to my blynk android app, and I installed blynk on my PI and when booting i get SSL not authorized, so I tried to make my own blynk server on the pi and same error, I just wanna control my pi using the blynk app and I don’t know how to, thank you for your help.

Which language are you using to program the Blynk client on your Pi?

Have you set-up certificates on your local server, and do you get any certificate errors in the server log?


I have no idea, can you explain how I check? also this is the video I followed Creating A Local Blynk Server Using A Raspberry Pi Zero W - YouTube

Well, that video shows a Wemos D1 Mini as the client device (4:15 in the video), and is being programmed in C++
Is that what you are using?


no im useing the PI as the client and server hosting device

ok i just restarted the whole thing, following this i redid all my work How to install Node.js library on Linux | Blynk Help Center and even when trying blynk-client nOFk7mX60ytr3LpscdiooAdCCxTmhnSO it dosnt work

im just loged in thru facebook, thru the blynk server and I put in the blynk-client f-OWL9DjxxWpUCLUvdIIB32SAzBbMD_P (got a new code now) and it still just keeps saying SSL not autheroized.

and the date is right on my raspberry pi

Okay, so you’re using NodeJS as your programming language.

In that case, you should read this:


This didn’t help me, I looked thru it all a bunch of times and most of it isn’t even for the raspberry pi, its for a Arduino.

I would just like simple and detailed working intrusions on how to make a blynk server on raspberry pi, thank you

In that case, you’re nor reading the link I sent you properly.
In that link, user kenarf asked “How to connect without ssl. I have raspberry pi 3 b”
The reply, from me, is a link to the solution, which is described by user mukeshsundaram and involves editing the blynk.js file to force TCP rather than SSL connection.

I’d suggest you re-read the link and make the changes to blynk.js, or abandon the use of the Pi as a client and use a NodeMCU instead.


I cant find any file on the pi called blynk.js and what line do I need to edit?

The path to the file and the details of which lines need to be edited are in the link I provided.

I don’t use the Raspberry Pi as a client, or code in NodeJS, so that’s all the information I have. If you cant make it work then I’d suggest using different hardware and a different programming language, such as a NodeMCU and C++, as in the video you were following.