BLYNK
BLYNK.IO       📲 GETTING STARTED       📗 DOCS       👉 SKETCH BUILDER

Spontaneous change of values of variables on the server

Hello.
I am using Blynk 2.0 and esp32.
There is a problem - a spontaneous change in data values ​​on the server and, accordingly, in the phone application and in the controller. This does not happen often - about once every two to three weeks. Last time happened yesterday at 21:50 and 22:12.

At first, I thought that these changes were initiated by the controller itself - that the error was in it. Therefore, I removed the Blynk.virtualWrite() function from the code. Thus, now the controller only receives data values ​​from the server, but does not write data to the server. However, the same thing happened anyway - at some point, the data values ​​on the server changed.
Tell me what information I need to provide to determine the problem.

Do you have any data invalidation rules set-up in the datastream advanced settings.

Do you have any automations for this template.

Is there any chance that you have another device using the same Auth token, or that data is being written from the API or Node-Red?

What do the reports show?

Pete.

If I understand your question correctly, the answer is no. I provide a screenshot:

No.

It’s impossible. The token is only used in one controller. I don’t use anything else (API or Node-Red).

Here is the most interesting.
I just opened the report and found a huge number of data record values from the user (from myself, admin), which in fact were not. Moreover, there are whole packages of changes within one second - it is not even physically possible to do this.
Can’t attach report - file type not supported…
Here is a screenshot from the report showing what happened yesterday - changing the value of a variable on behalf of the admin, and a huge number of entries in a couple of minutes… The value of the variable was equal to 55, then it is spontaneously overwritten with the value 45…

@Serg_Grn please try to reproduce and provide us with the mobile app logs. We’ll check. Most likely somehow controls on the UI are triggered when you open the app. But this is just a guess.
Do you have the latest app version?
What widget is used with that pin?

@Dmitriy, i sent, from mail: g9154600@gmail.com.
Application version 1.3.13 (66) (03.05.2022 12:17).
Widget - horizontal slider.

@Dmitriy, please let me know if the problem has been fixed? Since then, the error has not manifested itself, I want to understand if this is a coincidence or you fixed it.

Still no information?..