SparkFun Blynk Board not connecting to network?

Blynk app says "please check your intrnet conection and try again. (error:attempt to connect to host timed out). But my phone is currently connected to wifi. I can also connect to the BlynkMe YYGB SSID. My phone can browse internet and everyhting fine. The Blynk Board flashes purple color.

Need a bit more info…

  • Hardware details
  • App version
  • Phone type and OS version
  • Any code you are using
  • Cloud or Local Server
  • First time using Blynk, or just an issue with this particular project?

App version 2.18.0 (1). Phone is iOS and 11.2.6. I’m not using any code. I have a SparkFun Blynk board 8266.
Cloud server. It is my first time using blynk but I have made this servo move before using this tutorial. The app just says “No internet connection” and I know I’m connected to the internet. I also tried this in other LAN areas (plus at home) and is still does the same thing. I connect to the SSID Blynk-BBBB (with the 4 color scheme) and it connects there fine but then the board just flashes a purple light and the app wont connect. I’m following hardware config using the video below.

Hmm, OK, I have no idea about the SparkFun Blynk Board… have you tried asking on their forum?

The board starts flashing a series of 4 colors, The SSID pops up just fine “Blynk - YYGB” (Or any arrangement of colors) and I connect to that from my iOS device. Then the Blynk board then just flashes the color purple after that and in the app it says “Device offline.” I have tried this same process at my home and in different LAN networks. I know it isn’t a software issue on my Iphone either. It used to connect fine! I tried resetting with the small physical “0” button too. I am so confused by this. Please help. Thanks

I’m confused either, as there is nothing to look at. We know nothing about your hardware configuration, flashed sketch, blynk versions, etc… You said this is a Blynk error or issue. How do you know that? Glad to help, but how?

Thanks for the reply. I’m using blynk Version: 2.18.0 (1). I followed this tutorial (for hardware config) EXACTLY and my app on my phone still says “device offline.” How do I “flash” my sketch? It send an authentication token to my email but I don’t know what to do with it. Does that have something to do with it? The authentication token should be independent of the fact that I cannot connect my iOS blynk board app to the internet… See tutorial below

Hardly a tutorial. Just a “demo” show.

So You REALLY need to start from scratch…
You will need an Arduino IDE, a board definition (target hardware to program/flash)… etc, etc…
the auth token is an unique ID to identify your project.
You have a lot of reading ahead.: is a good starting point. Later on try sketch builder (top right of the page)

That makes sense. I appreciate the help. I read through alot of those things and have followed the tutorial. What I’m stuck on is why the app always says “no internet connection.” I have an ESP8266 SparkFun Blynk Board. My Iphone is definitely connected to a network and the internet works fine. It only doesn’t connect on this app. It seems I can’t do anything else until I get the app connected to a network. Please help.

@NewNorth6 Please don’t open multiple topics on same issue… I have merged both together here.

1 Like

That is why I had NO IDEA what it is all about… Ech…

I know nothing about their board. It looks like some commercial agreement between Blynk Team and Sparkfun. We have no look into their source code (or is it available somewhere?). So definitely it would be a good idea to ask those, who built that thing.

1 Like


Have you followed all this…

And did you ask for any assistance on the SparkFun site? This is a specialized board and may have specialized ways of working?