[SOLVED] Your Arduino UNO is not in network!

Hello dear Blynkers !
I’ve got a problem that’s when i want to start cntrolling via Blynk they said your Arduino UNO is not in network i have Arduino UNO REV3 , Arduiono Ethernet Shield !
please i need your supports to solve the problem !
Kind regards

1 Like

Please describe all your steps. Have you followed all the instructions on the http://blynk.cc/getting-started ?

Let us know

1- ulpoad the app
2- create an account and all of other steps
3- use an example from Blynk/Ethernet shield
4- Past the Auth Token
5- upload to my Arduino UNO and i start the app
and they said Your Arduino UNO is not in network i don’t know how to deal with that !!

What internet connection type do you use? (wifi, ethernet, usb?), in case of ethernet, wifi?

I use Arduino Ethernet Shield !

Could you please start Arduino IDE Serial Monitor and tell us what’s there. Thanks

[0] Blynk v0.2.1
[0] Getting IP …
[6460] DHCP Failed

I’m still Waiting the answer !


this error says your router doesn’t gives your arduino an IP address.
Try this sketch https://github.com/blynkkk/blynk-library/blob/master/examples/BoardsAndShields/Arduino_Ethernet_Manual/Arduino_Ethernet_Manual.ino and specify your arduino address explicitly.

IPAddress arduino_ip ( 10, 0, 0, 20);
Blynk.begin(auth, “cloud.blynk.cc”, 8442, arduino_ip);

either enable DHCP on your router.


in the last link you gave here ;


what exactly is meant to be changed? all the router info below from my own mac is meant to be changed in the sketche code is it? so all the numbers below?

IPAddress server_ip (10, 0, 0, 10);

// Mac address should be different for each device in your LAN
byte arduino_mac[] = { 0xDE, 0xED, 0xBA, 0xFE, 0xFE, 0xED };
IPAddress arduino_ip ( 10, 0, 0, 20);
IPAddress dns_ip ( 8, 8, 8, 8);
IPAddress gateway_ip ( 10, 0, 0, 1);
IPAddress subnet_mask(255, 255, 255, 0);

Yes, you have to configure it for your own network to work. This means handing out a free IP address and set the correct gateway, subnetmask and dns servers

@Lichtsignaal thanks for your help, got other simpler Blynk LED sketch to work.

Could you share your solution so that others can benefit from it? I wonder how you solved the DHCP error? I’m having the same problem.

I used a simpler arduino sketch in the end, other thread is here;

see Murilos answer 3 fron the bottom dated dec 15…
A bit of cable experimenation and reinstall of the blynk library did it.

I used ESP8266 wifi module. In serial monitor, it says connected to WiFi. But in Blynk app it says Arduino UNO not it network. Please suggest me any correction.

Does it work? because the not in network message is not always relevant. If the serial monitor says connected, it’s connected al right.

No, it doesn’t work.

did you select ESP8266 in the app or UNO?

In selected ESP8266 in Arduino Uno. Do I need to select in app too? Is there any provision for that?

Have you looked?