BLYNK
BLYNK.IO       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

[SOLVED] Unstable connection with the cloud

For a month my heating-management project was running extremely stable on a an Arduino Mega + ethernet shield.
My Blynk app runs on One+ Android.
The history graphs and the commands worked without loss of data and quickly.
But since 24th of may, all graphs and buttoms are dead on my One+.
I tried to get connected with an refreshed “auth. token” : no change.
I tried the most simple program (1 buttom - one led): this worked for a while, but not stable (alternatively variable number of seconds access / no access to the cloud).
I tried this simple tests with new project under the same account, but also under a brand new account : same bad result
I tried external and USB power supply without any change.
I tried the USB connection (blynk-ser script) : this connection to the cloud was very stable !!!
I tried Blynk application
The laptop used for the USB tests, was connected with the same router to the internet.
To exclude hardware failure,I double checked all the (one led / one buttom) tests with 2 different Arduino Boards and two different ethernet shields. The results were identically bad. I paid attention to use different auth. codes for each ethernet shield.

internet quality recently upgrade to 200/20Mbps, (relevant ? )

please help

Hello. You need just to update Blynk library for your hardware to latest version.

Hallo D, I did an update on the library , but no change…

What does serial debug shows?

Hi D,

``De schets gebruikt 20.900 bytes (8%) programma-opslagruimte. Maximum is 253.952 bytes.
Globale variabelen gebruiken 672 bytes (8%) van het dynamisch geheugen. Resteren 7.520 bytes voor lokale variabelen. Maximum is 8.192 bytes.

= serial debug ? 

I upgraded today from arduino 1.6.5 to 1.6.9 and also installed the most recent libraries .
The unstable communication however on the small "led + buttom" program has not changed.
(communication working very well for a few seconds , than not, then again etc ).
I keep getting messages on my tablet " your Arduino mega was disconnected"

No. http://docs.blynk.cc/#troubleshooting-enable-debug you need open serial print console in IDE after flashing

``244860] >vw[00]10[00]1
[245005] >[14|02|19|00|07]
[245007] >vw[00]10[00]0
[246076] >[14|02|1A|00|07]
[246079] >vw[00]10[00]1
[251671] <[06|00]*[00|00]
[256080] <[06|00]+[00|00]
[258081] <[06|00],[00|00]
[260082] <[06|00]-[00|00]
[262080] Heartbeat timeout: 262080, 246079, 260082
[265083] Connecting to blynk-cloud.com:8442
[265182] <[02|00|01|00]
[265183] <269a9bcb38954240b419807ecf71889f
[265225] >[00|00|01|00|C8]
[265226] Ready (ping: 38ms).
[265248] <[11|00].[00]e
[265274] <ver[00]0.3.7[00]h-beat[00]10[00]buff-in[00]256[00]dev[00]Arduino Mega[00]cpu[00]ATmega2560[00]con[00]W5100[00]build[00]Jun 1 2016 12:20:47[00]
[265467] >[00|00].[00|C8]


this is sequence of goodconnection - stopped - restart.....

this happens all the time

hallo D,

seems to be OK now.
Test-program runs without problems by slowing down the loop() …with a delay of 100ms .
when in an arduino sketch read or write instructions come to close after each other, Arduino comes in the disconnected situation …

(only reason I see for that is the recent speed update from my internet provider)

so : problem solved so far .