[solved] Sharing QR saved to Google Drive as text. Not an image

The docs are very clear on the basics of sharing a project with a QR code. However, when I tried to save my link (so I wouldn’t lose it), it saved as a text file, not an image or URL. The text starts with "IHDR sBIT IDATx ". I don’t see any docs explaining how to share via file. Is it even possible? What if I used a third party app to convert the text to a QR code?

It’s not clear to me whether I even need to save a link. Can I re-show the existing link in the app without spending another 1000e?

I figured out the first two questions. The TXT file that got saved (on google drive) is actually a PNG (image) file that saved with the wrong file extension. After renaming and opening the file I see a good QR code that successfully scans and launches my project via Blynk or QRDroid.

What follows might be more appropriate as a new topic…

However, when I send that same QR to a buddy of mine, he just gets a “can’t load project” message from Blynk. He’s using the latest iOS and Blynk. The QR was generated in latest Blynk for Android.

i think the project has to be “started” (with the play button) on the original acount where it was created, otherwise sharing won’t work.

Yes, did that. Shared project is running fine on 2 android mobiles, but failing to load on iOs.

There are some differences between the Apps for both OS types. The QR may contain info for Widgets that are not availed to the IOS yet.

I’ll keep that in mind, but I don’t have any exotic widgets yet; just these:

  • Value
  • button
  • LED
  • terminal

Yes[quote=“Gunner, post:5, topic:16255”]
The QR may contain info for Widgets that are not availed to the IOS yet

This shouldn’t be a reason to fail opening anyway. When the widget is not yet available, we show a “placeholder” widget there.

Please post a screenshot

Ahh, good to know.

Maybe I should have been more specific. :slight_smile: The point is that there is every indication in the UI and the documentation that if I touch that link button again, I get charged another 1000e, and I see no other link related controls. So, how do I re-show an existing link? The documentation should have made this as clear as making your first link, but it’ not mentioned at all.

In the Project settings, before you can hit the “Generate Link” button, you have to turn on sharing. You will also get an alert regarding not refundable 1000. If the sharing is already turned on, the “Generate Link” button is already active, and you won’t get an alert.

Understood, I can see that much. I really do appreciate that you’re trying to help, but this still doesn’t answer the question of how do I view an existing link that was already generated (days ago). You claimed it was possible without incurring another charge. I just want to know how, and I’m not about to go experimentally clicking all over the place, playing roulette with my wallet, just so I can precisely document every scenario. That’s something the developers should have done ages ago.

I’m going to mark this as “solved” because the issue in the subject line has been solved, and the rest of the discussion is a bit off topic.

Yes, I believe that as long as you don’t turn OFF the shared access, you can keep generating the link (no additional charges based on my testing). If however you shut off the shared access, then when you turn it on you get another energy charge.

I know that even small amount of expense can be a challenge for some (myself included), however you can always go the Local Server route and play to your heart’s content (as you manage your own energy allotments).