[SOLVED] Seeedstudio Ethernet V2 and Uno disconnected repeating

Trying the hello world setup for the Seeedstudio Ethernet V2 with an Uno. It connects via ethernet, then disconnects every 5 seconds. Message pops up on Blynk app on android phone “Your Arduino Uno Was Disconnected.”

//#define BLYNK_DEBUG
#define BLYNK_PRINT Serial    // Comment this out to disable prints and save space
#include <SPI.h>
#include <EthernetV2_0.h>
#include <BlynkSimpleEthernetV2_0.h>

#define W5200_CS  10
#define SDCARD_CS 4

// You should get Auth Token in the Blynk App.
// Go to the Project Settings (nut icon).
char auth[] = "9311MyAuthCodeHere335e18348b03";

void setup()

  digitalWrite(SDCARD_CS, HIGH); // Deselect the SD card

  // You can also specify server.
  // For more options, see BoardsAndShields/Arduino_Ethernet_Manual example
  //Blynk.begin(auth, "cloud.blynk.cc", 8442);
  //Blynk.begin(auth, IPAddress(192,168,1,100), 8888);

void loop()

From Serial Console:
[3303478] Connecting to cloud.blynk.cc:8442
[3303629] Ready (ping: 46ms).
[3308717] Connecting to cloud.blynk.cc:8442
[3308867] Ready (ping: 46ms).
[3313956] Connecting to cloud.blynk.cc:8442
[3314113] Ready (ping: 48ms).

Is this normal behavior? Or is there something weird going on?
On the Blynk side I just have a button set for D7 and tried it as both push and switch. No led lighting up on the Uno.



Hello, please try latest version from trunk/master. By the way which version do you have?

Hi Dmitriy,

Version 0.3.1. Just downloaded it yesterday.

I have 0.3.2-beta now. That seems to have stabilized it. Now in debug mode I’m getting codes through like >dw 7 0 and >dw 7 1 when I press the button.


Now to start blynking! :smiley: :smile: :smiley: :smile: :smiley:


1 Like