[SOLVED] Running Arduino IDE on Raspberry Pi library problems

Hi im very new to this and have made some good progress but I’m stuck, any help much appreciated. I see similar problems but nothing I do can resolve it.
I have installed the Raspberry updates and Blynk Library
I installed Anduino IDE on my Raspberry Pi and it works ok. I can pick any random code example and click compile no problem. So I need to install the blynk Library into Ardunio now.
I have tried two suggestions to install it first copy the library folders to my Sketchbook /home/pi/sketchbook and also using the library zip but still errors.
BlynkBuildTest.ino:24:36: fatal error;BlynkSimpleUserDefined.h: No such file or directory compilation terminated.

I even put the path in the #include to point to the file location in the blynk library.

Im new to all of this and have spent many hours trying to fix it, i dont know what else to try. Can anyone help?

@Steveb370 which version of the Arduino IDE did you install on the Pi?

Do you have a link?

The normal install of the IDE on the Pi is to be able to compile sketches that you then run on an Arduino, not a Pi. There is however a true Arduino IDE for the Pi.

Thanks Costas that sounds promising I have version I can’t remember where I got it from, I assume a tutorial. Is that correct?

What I’m trying to do is run IDE on the pi so I can program on the Pi and upload the code to an Arduino thats connected to the Pi USB port. The Pi has my local blynk server and should act as the wifi, hopefully.

it was a tutorial which gave sudo apt-get install arduino

@Steveb370 I would remove what you have with purge and use this tutorial https://medium.com/@ronm333/installing-the-arduino-ide-on-the-raspberry-pi-82301ab381b9

thanks again Costas. im following the instructions which look simple enough, looks so easy in the example :-). I couldent unpack it with the archiver utility it gave an error “An error occured” Please tick the store archiver output option to see. I cant see that option so I used the command line to unpack which it did aparantly ok.
So i get to the ./install.sh part and get an error. first line says its adding desktop shortcut and file associations for Ardinio.
the next one says cc.arduino.arduinoide.xml doesent exist in /lib, thats correct it doesent.
There are a few lines after that reporting “does not have proper vend or prefix” for the missing file.
I looked in lib and there are a lot of zips in there so maybe it didnt unpack everything because I had to use the command line? I dont know why I cant unpack this with the Archive utility I have unpacked other thinks ok in the past.

I couldn’t fix this but in case anyone else has this problem you can just run the executable without install.sh. I copied the unpacked archive to my desktop, run in terminal and much to my surprise it works perfectly. I installed the Blynk library through Arduino IDE Sketches add library, then uploaded my program to UNO from my Pi with no problems. Exciting stuff, thanks for your help Costas