[SOLVED] RTC widget lib problem

When i try to compile with the Blynk RTC
All the different lib are updated today. (11.april.2016)

I get this message :s

In file included from Vido_2016_April.ino:7:0:
/Users/SebTech/Documents/Arduino/libraries/Blynk/WidgetRTC.h: In function ‘time_t WidgetRTC_impl::requestTimeSync()’:
/Users/SebTech/Documents/Arduino/libraries/Blynk/WidgetRTC.h:36:5: error: ‘Blynk’ was not declared in this scope
Blynk.syncVirtual(WidgetRTC::mPin); // Request RTC widget update from the server

Are you sure you correctly installed library? You need manually copy it and unpack. Nothing more.

Dowloaded the zip from blank.cc (v 0.3.4)

Then unzip, then copy all 5 folders to the arduino libraries folder

I am using a Arduino Mega 2560 with ethernet shield.

This is my include at the top of the sketch

#include <Time.h> 
#include <Ethernet.h>
#include <SPI.h>
#include <TimeLib.h>
#include <WidgetRTC.h>
#include <OneWire.h>
#include <DallasTemperature.h>
#include <TimeAlarms.h>
#include <BlynkSimpleEthernet.h>

Do you need other info ? :slight_smile:

include Blynk library before Widget and others

Wow. nice. that worked.
Now it’s compiling with no problem :smiley: Thanks. !