[SOLVED] Raw .gz file

I’m trying to get the .gz files from the raw data storage for plotting in OpenOffice (lightsensors to see if I can automate light switches), but the when I decompress the .gz file I get a cpgz file which then again decompresses in a .gz file etc. etc. I’ve tried using the OS X Archiver app and something called The Unarchiver, but both can’t seem to get the contents of the archived raw data. Is there any way I can get to it? Thnx :slight_smile:

Could you please attach it here? Locally for me everything works (Ubuntu).


It’s here: http://lichtsignaal.nl/rommel/1571506409_v0-2015-11-30.csv.gz (the upload here only allows for images).

When I try to unzip manually (Mac OS X Yosemite) I get:

MacBook-Pro-van-Bastiaan:Desktop bastiaanvisee$ unzip 1571506409_v0-2015-11-30.csv.gz
Archive: 1571506409_v0-2015-11-30.csv.gz
End-of-central-directory signature not found. Either this file is not
a zipfile, or it constitutes one disk of a multi-part archive. In the
latter case the central directory and zipfile comment will be found on
the last disk(s) of this archive.
unzip: cannot find zipfile directory in one of 1571506409_v0-2015-11-30.csv.gz or
1571506409_v0-2015-11-30.csv.gz.zip, and cannot find 1571506409_v0-2015-11-30.csv.gz.ZIP, period.

1 Like

Is that the only file? Or this is happen with all?

No, with all files. I’m running latest local server on RasPi (0.11.4) and latest client on IOS (if that matters).

It even happens when I install Ubuntu, it says “not in gzip format” when I try to gunzip them.

And I’m losing vPins too again … I removed graphs with vPins 0,1 and 2 and I can’t add them again on the vPins :confused:

Ok. I need some time to investigate how that could happen. Regarding pins - could you please give steps to reproduce (Android, iOS? latest version?).

1 Like

I’m guessing same as last time, incompatibility between IOS/Android app. I use both devices with latest app. I’ll try to reproduce it, but for now it’s kind of crap because when I make a new dashboard I’ll loose my history.

You mean loosing data in history graph?

Yeah, when I make a new dashboard. But the loosing pins is just related to vPins on a regular graph widget.

@Lichtsignaal issue is fixed. Will release new server soon with updates. Funny thing - issue wasn’t in Blynk itself, but in 3-d party library =). " log file was renamed to .zip but not compressed" so you should be able to read it as csv.

1 Like

Awesome! Thanks for investigating!