[SOLVED] Push Notification Button

Yesterday, I was able to get the Blink example working with LED connected to D9 (with resistor).

Today, I am trying the Push Notification Button example.
Button is pressed is displayed in the Serial Monitor.
But I get nothing in the Blynk app where I had added a Notification Widget.
Not sure what else I can do to troubleshoot this.

Arduino Uno R3 with W5100 Ethernet Shield.

Edit: My Blynk app was “offline”. Now it is online and the app works.
Why does that happen?


What exactly?

The Blynk app was “offline”.
I don’t know what I did to make it come “online”.

I didn’t have that problem with the first Blynk app.

I think you mean not app but hardware is offline.

I don’t think so.
The text was that the blynkPushbutton was offline.

It wasn’t receiving the notification of the button press.

I re-loaded blynkBlink, and that worked fine. Just to make sure the Ethernet shield was still wworking fine.

Then I loaded blynkPushbutton again, and then it started to work.

I could see the Blynk app doing some sort of refresh.

Just weird.

Suggests you added some bad code in your new app but there are many reasons that MCU’s can go offline.

For example, If you are connecting via Ethernet to a router that is bridged via wireless to the main router then your near neighbour (or family member) simply booting up his / her laptop when they arrive home from work could disconnect your MCU from the internet.

Some Ethernet shields are quite flakey to say the least.

You need to ensure you have access to Serial Monitor until you have thoroughly tested your project and debug with this as the first line of your sketch:

#define BLYNK_DEBUG // comment out after debugging as it slows down your MCU