[SOLVED] Problems installing Blynk

Hi there!
Same issue here: I applied both methods.

  1. Downloaded Blynk_Release_v0.4.10.zip from your website, unzipped under the directory indicated in File->Preferences. All libraries are under folder /libraries of that directory, all tools are under folder tools/ of that directory.
  2. Cloned library from github and symbolic linked it under that File->Preferences directory, as I did for other projects.

In both cases, there is no way that any Blynk include file is imported when I select “Import Library -> Blynk”.
And, of course, when I open an example file from File->Examples, no include file is found for Blynk.

I am on Ubuntu 17.10

Thanks in advance for your kind help

@AndreCall You tacked on a “Me too” issue onto a very old topic, much has changed since then.

I have moved your issue into a current topic of your own.

Blynk has current How-To information in the Help Center. Please confirm you have followed the up to date info (Install manually, do not use the import method) then return here if you have further issues or questions. Thank you.

It is recommended that you completely remove the Blynk library you have installed first… just in case of file corruption.

Thanks @Gunner! I will redo all the process and will be back hopefully to mark this item as solved

Hi @Gunner,
I completely reinstalled everything: I downloaded the latest library revision, I unzipped it and now the content of “libraries” is under /path2mysketchbook/libraries and tools is under /path2mysketchbook/tools.

The I opened the Arduino Ide, loaded Arduino_Ethernet example, saved it with my auth token in place.

I pushed “Verify” on the Arduino Ide and got the same error:
Arduino_Ethernet_test.ino:40:33: fatal error: BlynkSimpleEthernet.h: File o directory non esistente
compilation terminated.

Arduino is connected via usb to a Raspberry Pi 3 and via ethernet shield to the net.
My Raspberry is updated to the latest sw/fw revision and ‘java -version’ returns
java version “1.8.0_65”
Java™ SE Runtime Environment (build 1.8.0_65-b17)
Java HotSpot™ Client VM (build 25.65-b01, mixed mode)

Just for info I succeeded installing and running a local Blynk server

Any other info needed?


This simply says it cant find the Blynk library where it needs to be

This part confuses me… are you running the Arduino IDE off of the RPi? If so, I have no idea how to further troubleshoot that.

Hi @Gunner,
thanks for your reply.
Here you are an image about my scetchbook directory.
Did I miss anything? What’s wrong with it?

About connection, my Arduino gets programmed via Raspberry, through the usb port.
Apologize if my sentence was a bit messy.

By the way I did the same operations on my Ubuntu workstation and the result is the same: BlynkSimpleEthernet.h not found.


@AndreCall connect the Arduino to your Ubuntu workstation. If you select an Arduino in the IDE and you have installed the libraries correctly i.e. manually, then BlynkSimpleEthernet.h will be there.

Hi @Costas,
thank you!
That’s the reason why I attached the image: to make sure that libraries and tools, installed manually, are in the correct place under my sketchbook path.

And the same error appears when I move my Arduino to my Ubuntu workstation, as I already wrote.

There should be something I am missing: do you need more info from my side?


The image relates to your Pi. I want to see the library folders on your Ubuntu machine.

Here you are (did it from scratch, manual library installation as described in the documentation):

@AndreCall I think you are missing the sketchbook subdirectory. libraries should be in the sketchbook directory and the Blynk libraries in this library directory. Same for tools, as branch off sketchbook.

@AndreCall I don’t like the look of your Arduino IDE. is not one I would use with Ubuntu. Download the correct version from https://www.arduino.cc/en/Main/Software

@Costas this is definitely a goooooood catch!

Now I can complete a ‘verify’ without any issue on both Ubuntu and Raspberry.

The learnt lesson is: Arduino package for both Ubuntu and Raspberry is out-of-date. Just use the software downloaded from arduino.cc

Many many thanks,

1 Like