[SOLVED] Performance degradation with let's encrypt certificates

Today I have deployed let’s encrypt certificates to my local blynk server. I have noted that administrator UI was degraded. Chrome didn’t load the admin UI with timeout error, app on phone (android and ios didn’t connect to server). Utilization on my server (Synology DS213j, Marvell Kirkwood 1.2GHz CPU, 512 RAM ) was 95%-100% (java blynk process) when I tried to log in. When I commented out certificate lines from config everything became fine. Tested on versions 16.4 and 17.
What the difference between embedded certs and let’s encrypt?

Hello. Thank you for reporting. What Java version do you have?

java -version ?

And what exactly did you comment?

Maybe you see some errors in blynk.log?


My java -version

openjdk version “1.8.0_60”
OpenJDK Runtime Environment (IcedTea 3.0.0pre06) (linux-gnu build 1.8.0_60-b24)
OpenJDK Zero VM (build 25.60-b23, interpreted mode)

When I ran it on Oracle Java™ it wasn’t worked. My previous problem.

I commented out that lines:


In blynk.log I didn’t saw any errors (on both variants) only warning:

WARN - An exceptionCaught() event was fired, and it reached at the tail of the pipeline. It usually means the last handler in the pipeline did not handle the exception.

@Xandr hm… Could you please update OpenJDK to latest version? It could be an JDK issue.

I installed java 1.8.0_101 and it was helped! Thank you!

  • I used this packet for Synology

java -version
java version “1.8.0_101”
Java™ SE Runtime Environment (build 1.8.0_101-b13)
Java HotSpot™ Client VM (build 25.101-b13, mixed mode)

Nice. Thank you for reporting back. Java is not perfect. Yet :slight_smile: