BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

[Solved] Nodemcu - Connecting to cloud.blynk.cc:8442


#1

Im having a problem which was reported before but it seems that the solution doesn’t work (or maybe I did something wrong)
I extracted all the four folders into libraries manually and I see them in the arduino IDE
It should be 0.4.3 and still cnt connect.

`þSÿÿ[254] Connecting to NOTYOURWIFI
[4257] Connected to WiFi
[4257] My IP: 192.168.1.26
[5001] Connecting to cloud.blynk.cc:8442
[11225] Connecting to cloud.blynk.cc:8442
[17600] Connecting to cloud.blynk.cc:8442


#2

That server was retired 6 months ago which suggests you haven’t installed the libraries correctly.

There are 6 library folders not 4, plus 2 folders in tools for the new 1.8.0 IDE. Which IDE are you using?

Completely remove the files and try again.


Esp8266 nodemcu v3 With blynk
#3

Thank you for the quick reply.I updated to IDE1.8.0 and placed all 8 folder in libraries
still get the same on the serial monitor

What should I do to connect to working server?

Connecting to NOTYOURWIFI
[4263] Connected to WiFi
[4263] My IP: 192.168.1.26
[5001] Connecting to cloud.blynk.cc:8442
[11231] Connecting to cloud.blynk.cc:8442
[17606] Connecting to cloud.blynk.cc:8442


#4

I think Im using the right version here is the content of “library” file on “blynk” folder
name=Blynk
version=0.4.3
author=Volodymyr Shymanskyy
maintainer=Volodymyr Shymanskyy volodymyr@blynk.cc
sentence=Build a smartphone app for your project in minutes!
paragraph=It supports WiFi, BLE, Bluetooth, Ethernet, GSM, USB, Serial. Works with many boards like ESP8266, ESP32, Arduino UNO, Nano, Due, Mega, Zero, MKR100, Yun, Raspberry Pi, Particle, Energia, ARM mbed, Intel Edison/Galileo/Joule, BBC micro:bit, DFRobot, RedBearLab, Microduino, LinkIt ONE …
category=Communication
url=http://blynk.cc
architectures=*
includes=Blynk.h


#5

Now you are just guessing, wrongly as it happens.


#6

what do you mean by guessing?
Have I done something wrong?

Thanks for your help!


#7

I do get this error when uploading the sketch. obviously I did not install those tool in a correct manner

Invalid library found in …Documents\Arduino\libraries\BlynkUpdater:
Invalid library found in…Documents\Arduino\libraries\BlynkUsbScript:


#8

Correct, read the docs in full.


#9

I think that these two folders should be placed here:
C:\Program Files (x86)\Arduino\tools


#10

@Brummer, no! it should go to sketchbook folder as it gets:
sketchbook is usually My Documents/Arduino

sketchbook/libraries
sketchbook/tools

Putting in Arduino Program Files is wrong.


#11

Thank you. They are now in documents/arduino/tools and I dont get the error of ivalid library but it doesn’t seems to change the output on the serial monitor.

Connecting to cloud.blynk.cc:8442

Any idea?(could anyone refer to the specific place in the docs?)

Thank you all.


#12

You will have to go over troubleshooting section


#13

There is nothing there about that kind of problem… I can connect to the WiFi but it seems like its trying to connect the wrong server (at least that is what I picked up from this forum).
Is there some file I can edit to change the server address to a correct one?


#14

You must have installed several libraries in different folders.
Remove all and reinstall the latest version


#15

Hi,
I’m having the very same problem. I removed all librairies and re-installed everything. Then I used the new update features in the tool menu to get everything up-to-date.
I have also tried to run the command telnet Blynk-cloud.com 4882 in terminal but nothing is happening.
Any thoughts ?


#16

it should print at least something :wink:


#17

8442


#18

Hi.
I had exactly the same problem. Kept prompting about “Connecting to cloud.blynk.cc:8442”.
It turned out that I had installed libraries for Cayenne and below that library, some old Blynk files were found and they were used instead.
I simple removed the Cayenne library and Blynk worked again :slight_smile:


#19

Oh yeah!! [quote=“Mads_Pedersen, post:18, topic:10361”]
I simple removed the Cayenne library and Blynk worked again :slight_smile:
[/quote]
It actually worked.
It was the cayenne library that caused the problem!!!


#20

Perfect :-).