[SOLVED] Lost project after creating certifcates

I had a Blynk local server working perfectly. Then I decided to follow the guide at http://www.instructables.com/id/How-to-Create-a-Blynk-Local-Server/ to create certifcates. All good and server running but it no longer recognises the user I had created and the project I was running. There was no change to the data folder location. Can anyone help with this?

Also have noticed that both before and after the above pages, the Admin web page config area doesn’t match the server and mail properties files I am using - server.properties just shows a few lines and if I click the mail.properties file I get “state change error: undefined”. Any reasons for this?

@dmorph1 do you see files in your data folder? What data folder did you use?

Hi Dmitriy,

Folder structure is C:/Blynk/server. In server there is server and mail properties plus certificate files plus log folder and data folder. The start line includes -dataFolder C:/Blynk/server/Data.

In the Data folder the server originally created a subfolder “data”. This folder has the u_ .user file plus a folder titled “my project user name”. In this folder there are all the gz and csv files from when I had the server running happily.

Thank you for responding so quickly.


Please double check you didn’t make any typo in your login name. What error do you see?

I’ve double checked to make sure that the log in name is exactly the same as in the .user file. I have also tried logging on with two different android devices and still keep getting “user is not registered”.

@dmorph1 did you type local server IP in app? In case you updated app recently you need to type server IP again.

Yes - there’s no change and I can create a log in and start a new project. However I would like to get my old project back which was built with purchased credits.

But you said you can’t login.

I can create a new account (same user name and password used) and then I can log in to that new account but I can’t see the existing project. However the new account is not appearing in the data folder. The server command prompt window did this:

C:\Users\David>cd C:/Blynk/server

C:\Blynk\server>java -jar server-0.17.0.jar

Blynk Server successfully started.
All server output is stored in folder ‘C:\Blynk\server.\logs’ file.
2016-08-30 21:41:12,815 Log4j2-AsyncLogger[AsyncContext@647e05]1 ERROR A Trigger
ingPolicy must be provided
2016-08-30 21:41:12,831 Log4j2-AsyncLogger[AsyncContext@647e05]1 ERROR Unable to
create Appender of type RollingFile
2016-08-30 21:41:12,909 Log4j2-AsyncLogger[AsyncContext@647e05]1 ERROR A Trigger
ingPolicy must be provided
2016-08-30 21:41:12,909 Log4j2-AsyncLogger[AsyncContext@647e05]1 ERROR Unable to
create Appender of type RollingFile

The log file is:
19:21:12.015 INFO - Using data dir ‘C:\Blynk\server\Data’
19:21:12.342 INFO - Region : local
19:21:12.623 INFO - Initializing mail transport. Username : dmorph01@gmail.com. SMTP host : smtp.gmail.com:587
19:21:14.994 INFO - Plain tcp/ip hardware server port 8442.
19:21:18.177 INFO - SSL hardware port 8441.
19:21:18.224 WARN - Found server certificates but no client certificate for ‘C:\Blynk\server’ path. Using one way ssl.
19:21:18.255 INFO - Application server port 8443.
19:21:18.910 INFO - HTTP API port 8080.
19:21:19.019 INFO - HTTPS API port 9443.
19:21:19.082 INFO - HTTPS admin UI port 7443.
19:21:19.082 INFO - Web Sockets port 8082.
19:21:19.113 INFO - Web SSL Sockets port 8081.
19:21:19.128 INFO - Mqtt hardware server port 8440.
19:22:28.675 ERROR - User not registered. Username ‘dmorph@bigpond.net.au’, /
19:26:04.462 ERROR - User not registered. Username ‘dmorph@bigpond.net.au’, /
21:15:12.298 ERROR - User not registered. Username ‘dmorph@bigpond.net.au’, /
21:18:39.965 ERROR - User not registered. Username ‘dmorph@bigpond.net.au’, /
21:20:10.383 ERROR - User not registered. Username ‘dmorph@bigpond.net.au’, /
21:41:07.542 INFO - Trying register user : dmorph@bigpond.net.au
21:41:07.558 INFO - Registered dmorph@bigpond.net.au.
21:41:07.823 INFO - dmorph@bigpond.net.au app joined.

From what I see - you initially run local server without dataFolder or another dataFolder. So that’s the reason for missing account. Try to search on your disk file u_dmorph@bigpond.net.au.user.

You also need to use latest 0.17.2 server.

Hi Dmitriy,

My old project is alive again! I found the new user file in server/Data so I deleted it and inserted the old user file which was in server/Data/data and it now works. I have the data folder set in the server.properties file as data.folder=C:/Blynk/server/Data and that is why I started the server without specifying the dataFolder. I think it all got a bit confused somewhere along the line.

Thank you for all your help. Blynk is a great system.

1 Like