(SOLVED) Local Server error "The command "openssl" is either misspelled or could not be found"

this is my problem with this command
openssl genrsa -out server_embedded.key 2048
the openssl

@samisamixp linux has openssl by default, Windows doesn’t. Ask the internet for the binaries.

1 Like

i have the openssl installer and did it but this appear again

Have you tried running as Admin?
What does the error message translate to in English?

1 Like

@Costas Google Translate says (yes, I typed it in from the screenshot… bored today :wink: )…

Openssl genrsa -out server embedded.key 2048
The command “openssl” is either misspelled or could not be found

@samisamixp You had posted into a solved topic that is over a year old. I have moved your issue into it’s own topic.

1 Like

sorry Thanks.

it s mean your command is false or could not found.

The error appears to come from whatever SSL/TLS Certificate generating program you are running (for Windows).

You will probably need to check with whatever install/help support it offers… it may be a simple path or syntax error.

@samisamixp I’m not sure you are sending the correct openssl command.

Blynk server GitHub states:

Generate own SSL certificates

Generate self-signed certificate and key

openssl req -x509 -nodes -days 1825 -newkey rsa:2048 -keyout server.key -out server.crt

Convert server.key to PKCS#8 private key file in PEM format

openssl pkcs8 -topk8 -inform PEM -outform PEM -in server.key -out server.pem

If you connect hardware with USB script you have to provide an option ‘-s’ pointing to “common name” (hostname) you did specified during certificate generation.

As an output you’ll retrieve server.crt and server.pem files that you need to provide for server.ssl properties.

@Costas From what I understand, the Blynk instructions use Certbot, however Certbot page claims it will not run on non-UNIX systems.

Get Started
Certbot is currently only available for UNIX-like operating systems. Although EFF’s Certbot might not work for your use case, there are many other clients written by other organizations and developers that you may be able to use to obtain a certificate from Let’s Encrypt.

openssl is for self signed certs not Let’s Encrypt certs generated with Certbot.

Try searching the openssl executable and run from the install dir. I think the install dir is not in your PATH enviroment variable.

Got it (OK, not really :stuck_out_tongue: apparently I haven’t a clue what the difference is :blush: ).

I shall stick with my first guess then…

1 Like

@Gunner Let’s Encrypt is an official (free) certificate provided by a “Company”, self signed have no authority but do serve a purpose.


Right now I’m working on the feature that will allow automatic certificate retrieval from Let’s Encrypt via Blynk server. Stay tuned :wink:.

1 Like

The command that he is using i think is from the youtube guide. Just last week i tried using them to make sure that they work. Its just that four lines of old code have been shortened into a single line. OPENSSL has not been added to the environment variables that is why he is getting this error.

1 Like

Windows does not know where to look for the OpenSSL program. It needs to be added to the path variable.
Right click on computer in explorer,
select Properties,
Click on Advanced System Settings,
select Environment variables (bottom of advanced tab)
Select Path in System Variables then click edit.
Add this C:\OpenSSL-Win64\bin (or where ever you installed OpenSSL).

Or just run the commands in the OpenSSL directory.

thanks everybody SOLVED

thanks alot