[Solved] Local Server connection and communication issues

I have two current projects, usually running simultaneously; A small one on a Pro Micro and a larger one on a Mega 2560. Both connect to the server via USB serial links - Micro using single COM port, Mega using two COM ports.

Both worked fine until two days ago, then the Mega project started to only send commands from app to board, but the app didn’t receive it’s usual feedback data. App showed Mega connection as active.

Micro project still worked fine.

Then yesterday, the Mega appeared to have stopped communicating all together with the server. App showed Mega as disconnected, but Mega would boot, appear to authorize and say connected (via monitor on 2nd serial port)… but no communication with app. Admin page shows (in Messages) incrementing Hardware Counts, usually up to around 500-700 then resets to 0.

Now Micro project is showing only one way communication with app and the Mega now rarely even “pretends” to connect.

Midway through all this I upgraded the apps to 2.2.0 and the server to 0.21.3… with no change in this strange behavior.

And just now I upgraded the app to 2.3.0. The Micro is still only one way data exchange (app to hardware with no feedback) and the Mega now shows connected in the app, and receives some of the hardware inputs (Timer count and LCD, but not Analog/Digital sensors or RGB feedback data to app display). Sliders, buttons or zeRGBa outputs do nothing to the hardware. While physical buttons on hardware still work and even provide feedback to app slider… Now it is almost the opposite of how it started??? arrrggg :confounded:

I can muddle my way through coding issues, but I am lost when trying to troubleshoot this local server… Logs don’t make any sense and right now I’m not even sure I am describing the issue correctly… sooo tired :sleeping:

Help me Obi-wan… before I start ranting about “Killing all Tech” :stuck_out_tongue:

Tell me what more info you need … as I just don’t know…

PS, small project works fine on cloud server… large project won’t fit due to low energy, and I can’t do anything about that right now (so I’m poor, don’t judge :stuck_out_tongue: )

USB connection are just for experiments. It wasn’t designed for stable and continues work. So we don’t give any guarantees here. Please buy ethernet, wi-fi, gsm shield and use it. It costs few bucks. Blynk for IoT and IoT doesn’t mean USB :slight_smile:.

1 Like


Ahhh, so that’s likely part of the issue… as I was just starting to work on bridging them as well… talk about USB overload :blush: Although it was all working great for a few days there.

UPDATE and SOLVED: Yes and thank you, you were correct; Even with possible Local Server issues. my flaky Ethernet Shield works better than USB, at least with the heaver “sandbox” projects I am running on my Mega 2560.

My Micro is running perfectly by itself on USB, so project density is a factor, and probably something in the routing bogs things down.

Exhausting ordeal, but more experience gained and lessons learned. Now sleep :sleeping: