[SOLVED] Invalid auth token

Hi, I am getting

[275681] Connecting to blynk-cloud.com:8442
[276312] Invalid auth token

it used to work last time before shifting to blynk-cloud.com server, i tried to refresh several times, but having the same result.

I just using a simple example to test.

#define BLYNK_PRINT Serial    // Comment this out to disable prints and save space
#include <ESP8266WiFi.h>
#include <BlynkSimpleEsp8266.h>

// You should get Auth Token in the Blynk App.
// Go to the Project Settings (nut icon).
char auth[] = "​​9bc1579557394381a23c3117bf4a49ad";

void setup()
  Blynk.begin(auth, "ssid", "password");

void loop()

Does your phone within same network as hardware?

So strange… if I see your post using my smartphone I can see several spaces before the 9 at your token. If I use my Computer the spaces are not there…

I don’t know if your token has those spaces or not but in case you have them, the reason for your “Invalid token” could be there…

1 Like

@Dmitriy ya, its under same network

@psoro but there is no spacing either on my pc or view from my phone

@psoro i tried to remove the first few character after the = sign, and retype again " and token, now it works. maybe that is the problem causing. But why it only show spacing in android phone?

I don’t really know @Eng, but, from now on going you can call me Mr. Holmes… :wink:

1 Like

@psoro Mr Holmes thanks for your info, and it works perfectly now, thankyou so much :grinning:

1 Like

A post was split to a new topic: Auth Token issue