[SOLVED] GPS trigger is not respond

I have a GPS trigger connected to the pin D0 on a nodeMcu board (esp8266), I defined the GPS area should monitor and have conducted tests in and out of the area, the pin D0 on a nodeMcu board does not change state (in NODEMCU pin D0 is connected to an LED). I tried to connect the D0 pin to a switch button and it works. The application is running on a mobile android sony z2. All this running on a local server (server-0.25.3.jar).

I believe you need to use virtual pins for GPS trigger. Then have code that triggers the digital pins.

  int state = param.asInt();
  if (state) {
      digitalWrite(0, 1); // or whatever works for NodeMCU
  } else {
      digitalWrite(0, 0); // or whatever works for NodeMCU

If that is the case, then why are there options to select analog and digital pins?

I try virtual pins for GPS trigger obtaining the same result. the GPS trigger is not respond. I upgrade server to latest version.

This widget needs to keep alive the screen to function properly? It does not work with the application in the background?

Should work just fine… as per documentation:

Well, when all else fails… show formatted code :wink:

Blynk - FTFC

Also… make sure you have allowed GPS permissions to the Blynk App.