[SOLVED] Failed to disable echo1

Hello guys!
My name is simone, I have recently descovered blynk. I need your help for my projet.
I want to connect my arduino UNO board to esp8266-01 but, when i try to connect esp8266 to my wi-fi network i have connection problems: “Failed to disable echo” but I can not understand why. The firmware of ESP is:
AT version: 20 2015 10:04:26)
SDK version:1.0.0
compile time:Mar 20 2015 11:00:32

Version of arduino 1.83 IDE

Connection Arduino – Esp:
TX – 3(SoftwareSerial)

[UPD: “Failed to disable echo” will most probably be reported as “ESP is not responding” now]

Try switching Tx/Rx wires. Also software serial is not the best. Do the baudrates on the ESP and Arduino match? E.g. are they both 9600? (I wouldn’t go any higher with software serial anyway).

I tried to switch Tx/Rx but nothing.

This is the sketch:

#define BLYNK_PRINT Serial

#include <ESP8266_Lib.h>
#include <BlynkSimpleShieldEsp8266.h>

// You should get Auth Token in the Blynk App.
// Go to the Project Settings (nut icon).
char auth[] = "xxxxxxxxxxxxxxx";

// Your WiFi credentials.
// Set password to "" for open networks.
char ssid[] = "xxxxxxxxxxxxxxxx";
char pass[] = "xxxxxxxxxxxxxxxxxx";

#include <SoftwareSerial.h>
SoftwareSerial EspSerial(2, 3); // RX, TX

// Your ESP8266 baud rate:
#define ESP8266_BAUD 9600

ESP8266 wifi(&EspSerial);

void setup()
  // Debug console

  // Set ESP8266 baud rate

  Blynk.begin(auth, wifi, ssid, pass);
  // You can also specify server:
  //Blynk.begin(auth, wifi, ssid, pass, "blynk-cloud.com", 8442);
  //Blynk.begin(auth, wifi, ssid, pass, IPAddress(192,168,1,100), 8442);

void loop()
  // You can inject your own code or combine it with other sketches.
  // Check other examples on how to communicate with Blynk. Remember
  // to avoid delay() function!

Can you connect to the ESP with that settings using a regular USB-to-Serial convertor? E.g. with that speed setting?

sorry i don’t understand…i have an Serial convertor (cp2102)
I do not know ESP very well

You can hook up the esp to a serial convertor to see if it works. It should respond to certain commands given in thr serial terminal like AT

Ok, I understand, I used arduino and it works. How do you do with my converter?

Same, you hook up the Tx from ESP to the Rx of the convertor. However, the ESP uses 3.3v logic, so make sure your convertor uses that too!!! If it uses 5v logic you may damage your ESP.

To be honest, all things considered, you are better off buying a Wemos D1 Mini. It has all the things built in, you can hook up a USB cable, program it with the Arduino IDE and never worry about that stupid ESP connections again. I use them all the time.

so i can replace esp8266 with Wemos D1 Mini? is compatible whit blynk?
sorry for my english but is rusty
anyway i’ve connect esp, to cp2102 :

Awesome, that means you ESP is working fine! I assume you entered the same baudrate in the Arduino as now in the serial monitor for connecting to the ESP.

And yes, the Wemos is fully compatible, but soooo much easier to work with than the standalone ESP.

Please, use a separate power supply… Esp will exceed what the Arduino can provide.

I will buy Wemos. So the communication is set to 115200 b, for arduino and for the Esp (how do you see in the sketch) which is the next step?

Ok, with a separate power supply! thanks but now there is another

problem :joy: do you have same solution?

The connection is unstable! but it’s a step foward!,thanks for your help

try esp - Arduino
TX- 3(arduino pin)
RX-2(arduino pin)

thank for your help. I have tried but I view “Failed to disable echo”

@smone upgrade to 0.4.8 and you should see a new error message.

sorry, why i have to udate?
how i can upgrade ? after upgrade i’ll to change something?

Are you still running Windows 3.1? No, that’s the reason to update.

Close the IDE. Copy and paste the 0.4.6 libraries to a new location for safe keeping. Delete the old 0.4.6 libraries. Copy and paste the 0.4.8 libraries to the same location as the original 0.4.6 libraries.[quote=“smone, post:18, topic:15283”]
after upgrade i’ll to change something?

Yes you will still have work to do but you will benefit from a nice new error message rather than the “failed to disable echo” message.

1 Like

@smone see https://github.com/blynkkk/blynk-library/issues/333 but it looks like the new error message has not been established yet.

At least with 0.4.8 all your widgets will work.