[SOLVED] Esp8266 OTA Update Stopped Working-

At some point, I upgraded my Blynk local server and firmware to the latest version and my wemos D1 minis began to immediately struggle to connect/ stay connected. I tried a number of things, but using the standalone example code seemed to work fine. I started removing various features I have in my code to get things to work- syncing pins, bridge etc, and finally came to the conclusion that the ESP8266 OTA update code (I believe the examples for this code come with the esp library… This is not WiFi manager code) that I have in my setup (starting OTA, giving the esp a name etc) was causing issues after I commented it all out. Immediately, my esp began connecting correctly. The odd thing is that my esp’s that I haven’t updated in a while, running the same code (but older Blynk firmware) seem to be working fine.


  1. I just wanted to make this known to Blynk and anyone in my shoes and…
  2. What’s my next best option for OTA updating my projects?

that is very important to be noted , i am on older version of sever/library and now i will hold any updates
as Arduino OTA is very important to me and a feature i can’t live without.

probably you should post your code here for examination. and if you are sure that the problems begin after the blynk update, you should change the category to “issues and errors”.

@wanek It was set at that originally… however that is a category for Blynk bug type issues, OTA is not Blynk specific, and failure was particularly suspicious after stating that firmware was also updated, so I changed it to the most likely category… sometimes users choose the big red category for anything from “need code” to syntax issues :wink: (not implying anything negative about this topic)

If however it looks like it is Blynk related, then it gets changed accordingly to attract the developers attention.

you are right, i just thought that if the same code worked before the blynk server update, and now it’s not working, that could be blynk related. but we need proof for this.

1 Like

I should mention that by 'upgraded firmware’s I meant I upgraded the blink Arduino libraries- not to be confused with upgrading AT firmware etc. I Only upgraded the Blynk server and libraries and found a potential issue with Blynks interaction with arduino OTA. I’ll post code when I get home later.

Thank you for the clarification… there is a significant difference between the two :wink:

Changes can trigger issues, but not necessarily be the cause of them. Key is determining the issue with investigation.

Along with your code, perhaps include more details like:

Make/model of ESP

Server, library & firmware versions, pre and post issue.

Flash memory size of the affected ESP, and if available, sketch size.

Thank you.

@scropion86 Scropion86 are you the maker of 3 relay boards?

Hey all- I haven’t had time to go back and check code, but I want to say that I upgraded to latest Blynk Arduino libraries, latest server, latest release candidate for the esp8266 Arduino libraries (2.4.x) but I downgraded Arduino ide to 1.6.7. Everything (Blynk and Arduino OTA) is working like a charm. I will also mention that I came across some evidence while googling that there were/are some issues between i2c and WiFi at some point in the Arduino esp libraries- one of the things I upgraded was from an analog to an i2c temp / humidity sensor when I began having these issues, but everything is peachy now.

I hope this helps anyone else who comes across this issue.

yes i have posted it before on the Forum here search by EgyIOT

Very nice!

Have you made any update on that project? I really would like to have the project files to start from where you have done, do make a new baseboard and expandable one, can you help me on that?

no i haven’t , but i suggest you to used itead sonoff relays as it’s cheap also better designed