[SOLVED] ESP8266-12F cant connect to WIFI

Hi, guys,
i have a little problem with my new ESP-12

when i’m using the ESP8266-01,
i flash the firmware using AT22SDK,
and write this following sketch

#define BLYNK_PRINT Serial

#include <ESP8266WiFi.h>
#include <BlynkSimpleEsp8266.h>

// You should get Auth Token in the Blynk App.
// Go to the Project Settings (nut icon).
char auth[] = "***";

// Your WiFi credentials.
// Set password to "" for open networks.
char ssid[] = "***";
char pass[] = "***";

void setup()
  // Debug console

  Blynk.begin(auth, ssid, pass);
  // You can also specify server:
  //Blynk.begin(auth, ssid, pass, "", 8442);
  //Blynk.begin(auth, ssid, pass, IPAddress(192,168,1,100), 8442);

void loop()
  // You can inject your own code or combine it with other sketches.
  // Check other examples on how to communicate with Blynk. Remember
  // to avoid delay() function!

Everything went well,
My esp-01 connected directly to my home Wifi and Blynk,

The problem happened when my esp-01 got burned, and i buy this new esp-12.
Everything looks good at first,
I flash it with the same AT22SDK, the ATcommand’s worked, I can send AT+CWMODE, Change CWMODE, Connect to AP, AT+CWLAP, AT+CWJAP, set esp-12 as AP, it’s all good,

But when i try to write it with the same Sketch, and reboot, the serial monitor stuck at
“[70]connecting to (myhomenetwork)”
, and no activity LED on my ESP-12,
it’s like it freezing when trying to connect to my home network,

What did i do wrong ? the wiring is

(ESP12 --- FTDI)
vcc --- 3,3v
grnd --- grnd
GPIO15 --- grnd
Rx ---- Tx
Tx --- Rx
CH_PD  ---- 3,3v

Has someone ever use this esp12 ?

Thx before.

First of all, you don’t need to flash the AT firmware. The Blynk sketch replaces it.

Must be the wiring then. Is the GPIO15 to gnd needed?

1 Like

Thx for the reply,

I try to flash it to know that the module works fine, and it’s worked fine with the command to connect, or create AP,

but when i write the blynk sketch, it got stuck on connecting to wifi,
[70]connecting to (myhomewifi), and stop there.

from what i read, yes, the GPIO15 is connected to ground, i
t’s not working anyway, when i disconnected it.

Can you try rebooting your router? It could be the ARP table has issues with the mac address.

Wow, it worked !

Thank you so much, @Lichtsignaal

but i think, this esp-12 has weaker signal then the -01 before, because when i try to reboot, it’s like 3 out of 5 times, it won’t connect.

@ferrizall think you might be right. Whenever I use the nasty 01’s they trash all my WiFi connections in the immediate vicinity. I think Espressif noticed this and turned down the signal strength on later models.

yes, right…!

Oh, btw @Costas, while you here, maybe you can help me, since i burned out my esp-01 because i hooked it up directly to my motor driver input.,

so, now i’m using, the Logic level converter,
what i wanted to do is hooking up my GPIO2 and GPIO0 , to the in1, and in2 of my L298 motor driver,
the problem is my multimeter was lost, and i dont want to waste another esp8266 just because of the wrong wiring,

So, can you help me to wire this with Logic Level Converter thing?
I have independently 12v input to the L298 and independently 3.3 v input to my ESP.

Can i just wiring the GPIO to LV1 LLC and the motor in1 to HV1 LLC?
I still need other 5v and the 3.3v input added to the Logic Level Converter ?

sorry it’s a bit out of the topic that i created.

Create a new thread.