[SOLVED] ESP 8266 RF remote not working

Hi I have been using blynk RF remote control using esp8266 12e board it was working fine but last three four days It was not working, when I press button it showing re connecting and automatically button state changing from off to on but no functioning is happening .please somebody can help me.

@sat what is ESP 8266 RF remote?

ESP8266 12E standalone or with other hardware? If other hardware what is it?

Android or iPhone?

Please provide sketch but ensure you highlight the sketch and press the </> icon so we can actually read the sketch.

Yes it is ESP8266 12E standalone using Android. Rf remote is imitating ready made RF remote control code and transmitting through RF module using blynk. It was functioning befor. The code I will send evening when I reach home.
Thank you

@sat we also use ESP’s for RF stuff.

Do you use a library for the RF part or is it all coded directly in the sketch (we don’t use a library)?
Which version of the IDE are you using and has it offered to update various libraries since your system stopped working?

I am using RCSwitch.h Library and IDE 1.6.5 regarding the updated library I am not sure.If you have a similar stuff, can you please provide the link to update library.
Thank you

If you are only on 1.6.5. then you will not have the semi automatic library update facility. I think it was introduced from 1.6.6. We are alternating between 1.6.5 and 1.6.7.

So we can probably eliminate a change to RCSwitch or any other library being the cause of your problem.

From my experience the main reason things don’t work as expected is because I have wired them up wrongly or a wire / connection has become loose.

Do you happen to have a DVB-T receiver to listen for the RF transmission on 433.92 Mhz?

Maybe add some LED (virtual or physical) notification code to the RCSwitch section of your sketch to be sure it is be called from the Android button widget.

char auth[] = " ";

This is sample code I used. I have the RF receiver unit but not detecting the button press.As you said let me check again any hardware or wiring problem.
Thank you

Hi I have checked wiring and hard ware I couldn’t find any fault, still not working.

@sat the github at https://github.com/sui77/rc-switch shows the header was updated 9 days ago. Might be a coincidence but it seems to tie up with when your system stopped working.

Are your libraries tied directly to Github as the change 9 days is not an official release so your libraries shouldn’t have changed. Can you try an earlier RCSwitch.h or at least check the date of the file on your system?

I have another ardunio with Ethernet shield their I am using the same RC Switch library with another android software it is functioning with out any error .Is it any problem with blynk or cloud connection?

@sat yes it suggests you have a Blynk problem rather than a problem with RC Switch.

Perhaps go back to turning an LED on and off with Blynk and then work back up to RC Switch. Cloud is working fine for me here and I’m sure we would have known if the system had been down in the last week.

Per your OP you say ‘automatically button state from off to on’ how is the ‘automatic’ bit working as I can’t see anything in your sketch that is automatic.

Automatic means in the button widget when it press the button state showing blinking on off fast, normally when press a button widget first it will show on next press show off, but it now shows on and off together with in second.

That sounds like your problem. There is a bug with the latest version of the app which shows incorrect on / off text but the buttons still work as they always have. Or I should say they work ok with Android.

Are you Android or iPhone?

Is the button PUSH or Switch mode?

Mine is android and PUSH mode.

Ok your dates tie up with a recent Android update. PUSH mode on my Android is fine except the text bug.

Perhaps describe in detail what happens including the Andorid version and phone model for the Blynk guys to check into.

Hi any blynk team member can help me ? Thanks

Actually, we can’t check with this hardware. Ideally, you should inspect the signal line with the oscilloscope to see if it is correct.
Anyway, you need to narrow down the problem

@sat please describe the ‘bug’, in detail, with your Blynk buttons without referring to RF.

Hi finally I found the reason, rf module was not working I changed the module now it is ok, thank you very much for the support especially @Costas was trying to help me a lot.

1 Like