[Solved] Error: Unable to access jarfile server -0.25.4

Hi everyone.

I’m a new user of this forum, and a newbie on Blynk.

Today, I’ve installed Blynk in my RPi 3, and everything went smooth. I’ve configured mail.properties and server.properties exactly as the tutorial explained, and it worked.

After that I’ve done an apt-get update and upgrade, and now everytime I start Blynk server, I get the message:

pi@raspberrypi:~/Blynk $ java -jar server-0.25.4 -dataFolder /home/pi/Blynk
Error: Unable to access jarfile server-0.25.4

Does anyone have any ideia of what might happened?


Yes, you forgot to add the extension " .jar" to the filename " server-0.25.4" :slight_smile:

1 Like

@Lichtsignaal thanks for your help.

That was one of the attempts I’ve made, after I googled the problem.

But even with the extension the problem remains.

can you do in the Blynk dir:

ls -ltha

and post the output here? I’m thinking you have a permissions problem with the file. You can also retry downloading it.

@Lichtsignaal, the output you’ve asked…

So have you run with “.jar” part? What is the output?

Hi Dmitriy.

Yes I’ve run it with .jar and the output is the same… :cry:

Please post exactly command here.

I’m using:

java -jar server-0.25.4.jar -dataFolder /home/pi/Blynk

Ok. try to remove jar file and download it again. Maybe it is corrupted.

I’ve done it.

Deleted and downloaded again… and it works!!!

However, it’s strange because I’ve forgotten to download it to home/pi/Blynk file, and it runs… tried to put it in the correct folder and it won’t run.

Apparentely it will only run in home/pi…

Try adding ./server-0.25.4.jar

The ./ in Linux means “current directory”.

Meanwhile, I’ve made a clean install, and it is working great.

Next step, homebridge…

Thank you all for your amazing help…

1 Like