[SOLVED] Error on Certificate generation

I have this kind of error, what should i do?
Im newbie here, just using blynk for my project

Hello. Did you add port forwarding as stated in docs?

You need to start server on port 80 (requires root or admin rights) or make port forwarding to default Blynk HTTP port - 8080.

I already start the server at port 80, i think the problem is at server. host which i dont have my own host or domain

So what exactly do you expect from certificate generator in that case?

any alternatives sir? or is it ok if i disable auto generation?

That’s ok. Server has embedded certs.

Ok sir, so how can i enable the email to notify me or my client?

18:52:29.354 INFO - Region : local
18:52:30.501 INFO - Initializing gmail smtp mail transport. Username : myemail@gmail.com. SMTP host : smtp.gmail.com:587
18:52:30.557 INFO - Didn’t find Let’s Encrypt certificates.
18:52:30.559 WARN - You didn’t specified ‘server.host’ or ‘contact.email’ properties in server.properties file. Automatic certificate generation is turned off. Please specify above properties for automatic certificates retrieval.
18:52:33.215 INFO - Hardware plain tcp/ip server listening at 8442 port.
18:52:33.218 INFO - Hardware SSL server listening at 8441 port.
18:52:33.219 INFO - Application server listening at 8443 port.
18:52:33.220 INFO - HTTP API and WebSockets server listening at 80 port.
18:52:33.222 INFO - HTTPS API, WebSockets and Admin page server listening at 9443 port.
18:52:33.223 INFO - Mqtt hardware server listening at 8440 port.
this is my blynk.log is it ok with this kind of log?

Read the docs regarding this.

i already did that but the problem is i dont have any host or domain to be input at the server.host

Yes it is.

ok so i will just ignore the WARN? is it right?

Yes it is and if you don’t receive emails the problem is elsewhere within your set up e.g. not using gmail, not configuring gmail correctly etc

thanks sir, i already set up my gmail at mail.properties

Having the same problem. Looks like the domain lookup fails. My guess is it’s because I’m usin a dynamic domain