[SOLVED] Display widget shows dashes after stopping dashboard

When I stop my dashboard on the app two of my value display widgets are replaced by dashes and stay like that after restarting the dashboard. Am I right in thinking the app should remember the previous values and then automatically update the display when you restart? At the moment the dashes stay until the next time my code changes the value then it’s displayed :thinking:

It might make more sense with pictures of my dashboard

Full display and running nice

Dashboard stopped

Dashboard started restarted

Ive just noticed its 3 value displays,the 3rd one gets updated every 30 mins by simple.timer and only seems be updated if the app is open and running

Do you use latest app version? Ios, Android?

Yes latest iOS.
Same results happen(values replaced with dashes)if I come out of the app for some time but leave dashboard running :confused: I’m sure it’s only started since last app update

Please give me your login name.

History graph using any virtual pin just displays “no data” also :confused:

Dashes issue fixed. Regarding history graph - are you sure you have data for that pin? What pin did you choose?

The fix doesn’t seem to work(one display seems to work now) I have the same issue with LEDs forgetting state when the apps stopped and restarted on another dashboard.
App running fine

App stopped

App restarted

I’ve tried each virtual pin I use for the graph,none seem to work,same result on all dashboards. Also when I stop and restart the dashboard it says at the top of app esp8266 is offline for a few seconds so I’ll try a better power supply. Is is possible for the app to cause disconnection?

Will this bug be fixed soon? I found this a big problem. I can’t use the app for my project because every time i open the app the widgets state is not updated… :pensive:

It was fixed. Do you use latest app version? Ios/Android? Local/Blynk server?

Still not working properly for me either. I assumed when you said it was fixed it would come with the next app update as it seemed to start after previous update :confused:

I have 1.9.10 and i use Blynk server

All of the app issues I had seem to be fixed since the latest library and app update.
I’m looking forward to using the rtc
Thanks for all your hard work :sunglasses:

1 Like