BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

[SOLVED] Can't open Administration UI with new Version 13.1

#1

Hello,

since i have updatet from version 12 to version 13.1 i can’t open the Administration ui. (https://192.x.x.x:7443/admin)
I’m confiused about the server.properties. In the official documentation you say

https.port=7443

In the community forum i saw
server.admin.port=7443

On Github the parameter name is administration.https.port=7443
What is wright?

I have tested all this paramters. But nothing happen. (Google Chrome: Error connection reset)

My server.properties is as follows:

#enable or disable administration UI
enable.administration.ui=true

#comma separated list of administrator IPs. allow access to admin UI only for those IPs.
#Leave empty in order to allow for all. By default allow access from local host.
allowed.administrator.ips=

#admin monitoring port.
#https.port=7443
#server.admin.port=7443
administration.https.port=7443

#comma separated list of users allowed to create accounts. leave it empty if no restriction required.
allowed.users.list=

#URL Path
admin.rootPath=/admin

On blynk.log i see nothing too.

22:18:21.474 INFO  - Enabling Web Sockets.
22:18:21.475 INFO  - Web Sockets port 8082.
22:18:21.501 INFO  - Enabling Web SSL Sockets.
22:18:21.552 INFO  - Web SSL Sockets port 8081.
22:18:21.587 DEBUG - -Dio.netty.eventLoopThreads: 8
22:18:21.721 DEBUG - -Dio.netty.noKeySetOptimization: false
22:18:21.721 DEBUG - -Dio.netty.selectorAutoRebuildThreshold: 512
22:18:21.888 DEBUG - -Dio.netty.initialSeedUniquifier: 0x2b07da2679503d8a (took 5 ms)
22:18:22.046 DEBUG - Loopback interface: lo (lo, 0:0:0:0:0:0:0:1%lo)
22:18:22.050 DEBUG - /proc/sys/net/core/somaxconn: 128
22:19:21.313 DEBUG - -Dio.netty.recycler.maxCapacity.default: 262144

Can you help me. Thanks

0 Likes

#2

Ok i have the solution.

If i leaf the parameter allowed.administrator.ips=

empty, i can’t connect to admin ui. If i set the netmask allowed.administrator.ips=192.x.x.x/24

i can connet to the ui.

1 Like

#3

Hello. Properties were changed a bit. The correct are those in documentation. You need only those :slightly_smiling:

admin.rootPath
allowed.administrator.ips
administration.https.port 

allowed.administrator.ips if empty - no access to admin.

0 Likes

#4

ok thanks. Can you correct the documentation for all of us, please.
the documentation says about the alowed.administrator.ips parameter:
Leave empty in order to allow access for anyone
Thanks!!!

0 Likes

#5

Nice catch. Thank you for pointing. Fixed.

0 Likes

#6

I cant access the admin UI, I already made some changes in the server.properties file, below are my settings:

ADMINISTRATION SECTION

admin.rootPath=/admin

administration https port
administration.https.port=7443

comma separated list of administrator IPs.
allow access to admin UI only for those IPs.
you may set it for 0.0.0.0/0 to allow access for all.
you may use CIDR notation. For instance, 192.168.0.53/24
allowed.administrator.ips=192.168.100.14

comma separated list of users allowed to
create accounts. leave it empty if no restriction required.
allowed.users.list=

I re-start the server and enter in my browser this URL path

https://192.168.100.14:7443/admin

but I cant access the admin UI.

0 Likes

#7

It should be IP of machine from which you try to access Admin page and not IP of server.

0 Likes

#8

I try to change it to allowed.administrator.ips=192.168.100.3 and access from my device with same ip address but cant access also try to change to allowed.administrator.ips=0.0.0.0/0 but still cant access https://192.168.100.14:7443/admin

0 Likes

#9

Are you within same network? Maybe your router blocks 7443 port?

0 Likes

#10

yes, try to check my router

0 Likes

#11

Hello Dmitriy,

I try other application using port 7443 and its working fine. but it cant access the the admin UI.

0 Likes

split this topic #12

A post was split to a new topic: No access to the admin page

0 Likes

closed #13
0 Likes