[SOLVED] Can't login to the new ios app with local server


I just installed the latest server on my pc, 0.25.0, I can connect to the admin page and I even see my other account there with all the widgets and everything laying around there.

but I can’t connect from my iPhone, it says I have no internet connection, I tried both on the wifi and without the wifi. I don’t understand what am I doing wrong… :frowning:

I searched everywhere for the answer… found nothing please help me as I’m unable to login.

Thanks in advance.

Hello. Do you see any error in server logs? Maybe something had changed on your router? Where is your server installed?

the server I installed is on the same computer as the old server I had, nothing was changed on the router as I manage it and I changed nothing on it. and on the server logs I see nothing…
on the app it says connecting when I enter the username and password… (which I have changed by the way so I can do that as well)… and after 1 minute it says I have no internet connection… :frowning:

Normally when it says you have no internet connection it’s because you don’t have a connection to the internet, simple :slight_smile:

To be serious for once, very, very occasionally an error message can sometimes be completely wrong, but it’s rare.

Never touched an iPhone but it’s fairly similar to an Android device. Is your iPhone trying to use WiFi or 3G / 4G?

3G / 4G can give geo-dns issues.

Does your browser work on the iPhone i.e. do you really have an internet connection?

I have internet on my phone, I surf and FB and check for emails… if I didn’t have internet on my phone I’d know.
I tried both from the wifi and the 3g… nothing

1 Like

What IP do you use for connection?

the ip I get from what is my ip address website.

I even tried the network IP.

Also I forgot to mention I uninstalled the app and reinstalled it.

You need to stick to one method because each method has the potential to give you a different server but as you are referring to a local server that shouldn’t be an issue, neither should geo-dns problems.

Were you OK with the iPhone and local server on the version before 0.25.0 or is this your first attempt at using a local server on a PC?

it’s my 3rd. I removed all traces of the old ones and started from scratch! now it’s running and I can see the account I had and all it’s widgets in there and I can’t get to it or even connect from the phone with the admin account or whatever it is.

it gives me the same error.

3rd at 0.25.0 but never used local server before, right or wrong?

no sorry,

I had 0.24.something… and before that I had 0.21.something…
this is my first attempt on the 0.25.0

Please post a screenshot

There you go. not sure how it can help… :wink:

I see you are using the stock admin account on your login page… have you tried logging in with your (other) account instead? The one with all your widgets etc.

PS, I just delete the stock admin account and it has never bothered me again, even after upgrades.

of course I tried with my old account. I put that one because I don’t want everyone to see my email and I’m too lazy to blur it out. :slight_smile:
but it gives the same result.

1 Like

Gotya! Like the computerized devices we work with, “we” sometimes take things literally here… a missing bracket, comma, misspelt word, use of slang… ah ha! THERE is your problem :stuck_out_tongue:

It is likely the server end and not the app… but have you tried logging into the cloud just to check app function?

I just did and I got in…

so now what?

Now the focus is on your server/network… the address, port, router, etc. Never assume that nothing changed, they can be fickle beasts.

Unfortunately at this point, short of you testing and documenting, every, single, step, you have done, for us to double check, you are your own best troubleshooter.

That said, here is another test for your server… try to create a new account on it, via your app.

tried that already before I even posted here… didn’t work…

looks like I’ll try to remove everything and start over. :frowning:

Just a tip that if you need a more detailed error description, you can log into a Cloud account and from the ‘About’ page send yourself (or us) the logs file to check.

1 Like