BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

[SOLVED] Can't load library

I can’t get the Blynk Labrary to load. I am adding the zip file to the IDE but get the error below.

Error compiling.
Specified folder/zip file does not contain a valid library

Can any one help a noob.

it’s in Portuguese , but you should get the idea.

Carl, you need to follow the instructions on Arduino website: https://www.arduino.cc/en/Guide/Libraries

Have you ever installed any arduino external library?

  1. Download Blynk_v0.3.1.zip
  2. Unzip it. You’ll get the folder named Blynk_v0.3.1
  3. Inside this folder there are 4 folders:
  4. Exit Arduino IDE
  5. Select ALL of these folders and move them to:
  • on Windows: My Documents\Arduino\libraries\
  • on Mac: Documents/Arduino/libraries/
  1. Open Arduino IDE
  2. In the top menu go to:

OR

  1. Click : Manage Libraries

  2. Type Blynk in the search field:

  3. Choose this library, press Install

Blynk does not show up in the list.

I’m out of options… :frowning:

  1. Have you tried the first option I described?
  2. Try reinstalling Arduino IDE
  3. Did you manage to install any 3rd party library for Arduino?

I’m not sure if this has been resolved, but make sure you bring out all the Blynk folders from the unzipped folder Blynk_v0.x.x into your libraries folder as separates (See picture).
I hope this makes sense and/or clarifies the process.
Cheers!

You should use IDE 1.6.5

I’ve followed the arduino.cc install library guides, and the guide in this thread and I still cannot get blynkesp8266wifi.h to highlight in blue.

@BiggestMarioFan are you sure you want blynkesp8266wifi.h ?

The 4 libraries available from Blynk are shown in the image 2 posts above this one.
Are you using an ESP as a standalone device or with an Arduino?
Which version of the IDE are you using.
Where is your sketchbook located as there should be a libraries folder within the sketchbook including any additional libraries you have added to your system?
Are you suing 0.3.1 zip or 0.3.3 beta zip from Blynk github?

I meant BlynkSimpleESP8266.h

ESP-12 (NodeMCU) as a standalone device, compiling on Arduino IDE 1.6.7
Sketchbook is in’ home/Documents/projects/HotWaterController’ and I’m using 0.3.1 zip from Blynk GitHub library (I’ve also tried blynk-library-master.zip, but can’t remember where I got it from, it’s not got the HardSer & SoftSer and SimpleTimer folders.)

Can I not have my libraries in the Arduino/libraries path, why would I have to put them in the sketchbook path? Surely that’s defeating the purpose of a common library for all sketchs, instead of having the library replicated inside each sketch’s path.

I guess you can have the libraries in your main Arduino libraries folder but I don’t have a problem with the additional libraries being in the sketchbook libraries folder.

Have you chosen the NodeMCU board in the IDE?

I hear bad things about versions of the IDE beyond 1.6.5 but I didn’t think it was a library issue. Are you able to try with 1.6.5?
You are using the easiest zip (0.3.1). I’m still a bit confused with your statement that you cannot get blynkesp8266wifi.h to highlight in blue, maybe that is for versions after 1.6.5. I use ESP generic rather than NodeMCU but with either board the Blynk standalone doesn’t include the header file you refer to.

The Blynk standalone sketch is shown below (from File, Examples, Blynk, Boards and Shields in the IDE).

#define BLYNK_PRINT Serial    // Comment this out to disable prints and save space
#include <ESP8266WiFi.h>
#include <BlynkSimpleEsp8266.h>

// You should get Auth Token in the Blynk App.
// Go to the Project Settings (nut icon).
char auth[] = "YourAuthToken";

void setup()
{
  Serial.begin(9600);
  Blynk.begin(auth, "ssid", "pass");
}

void loop()
{
  Blynk.run();
}

I confused the matter. I meant to say I’m trying to use BlynkSimpleEsp8266.h, and it’s not turning orange which would otherwise indicate the compiler has located the header file. I’ve chosen NodeMCU 0.9 board in the IDE, and have moved the 4 blynk library folders to inside my sketch’s folder in my ‘/documents/projects/HotWaterController/’ path and renamed the old copy in Arduino/libraries with ‘_1’ so the compiler will ignore that path and use the alternative. I’ve restarted the IDE but the header doesn’t turn orange like the rest.

I’ve tried esp generic board, but no luck.

Incidentally I can get esp8266wifi.h to turn orange, but I can’t find the file when I do a system wide search, I’d like to know where this is located!

I know this is definitely a problem with library paths, it’s just a matter of knowing where it should be.

You should not rely on IDE highlighting, actually it’s not indicating “the found header”.
Just extract all the folders into libraries directory, and try the examples!
If Arduino allows you to select examples - the library is there (examples are IN the library).

@BiggestMarioFan I messed up my libraries a few weeks ago and I know just how frustrating it is when such a fundamental step doesn’t appear to work. It took me about 24 hours to sort out something I know should take a few minutes.

I gave up trying to find various headers as I too searched the libraries in vain. I think the answer is that some are in the core for the board you select and esp8266wifi.h doesn’t come from Blynk it comes from Arduino ESP (or whatever they call it).

Do you have access to the Blynk examples through the IDE?

Where did you find reference to BlynkSimpleEsp8266.h as I can’t see it in the ESP standalone sketches?

1 Like

@vhymanskyy

All the blynk folders are in the libraries directory, and I can access the examples. The core header files like esp8266wifi.h are ok, but none of the blynk headers. I can see the headers in the libraries/blynk path but the compiler cannot! Interestingly, when I put /Blynk/some_header_file.h it highlights the word Blynk in orange as if it’s found the blynk folder in the libraries path, but doesn’t ‘drill down’ to the actual header file.

@Costas

BlynkSimpleEsp8266.h is in the blynk libraries folder.

Pleasse post a screenshot of your libraries folder or it’s structure, so that Blynk is seen

I managed to solve the problem on my own! I had to change all calls to headers within headers so that the ‘/’ in the library paths were ‘’. It’s because the github repositories are written in linux, and I’m trying to compile them in Windows!

i have the same problem of installing library you have but i cannot understand your conversation, plz explain it…

@rose take a look at the last 6 or 7 posts in this thread [SOLVED] Blynk <-> esp-link