[Solved] Bug with RTC and latest Android version


Think something is messed up here. My project has been working for weeks flawlessly. I have the iPhone and Android version of Blynk on 2 devices. Updated the Android version with one of the fixes being RTC no longer needs a Virtual pin. However, my sketch still has it in there, and so does my iPhone version. Looks like my Android version of the app clears out the pin, and my iPhone version registers none. So, your Android app is clearing it out for the iPhone app. Can you either fix this, or update the iPhone app and provide an updated sketch for attaching to the RTC widget pls.

To clarify, what is happening is if I edit the app in Android, it erases the virtual pin for RTC, which messes up my iPhone version and my device. I have to go back into the iPhone version, add the virtual pin and it works. Just confirmed. Although not earth shattering, it’s a pain that my device can easily get messed up by this…

Hello. This is not a bug. You need to take latest lib and use RTC without pin - https://github.com/blynkkk/blynk-library/blob/master/examples/Widgets/RTC/RTC.ino

Does this mean that I also just leave the RTC pin blank in my iPhone app? BTW - although not a bug, it would have been nice to see this risk being called out. I doubt I’m the only one with both Android and iOS versions of Blynk running at the same time. I didn’t even mess with RTC, it just blanked out the v pin when I went into edit mode on the Android App.

FYI. Still not working. Both my apps updated and now do not reference a V pin and I updated my sketch to remove the line BLYNK_ATTACH_WIDGET(rtc, V5); my Arduino environment is using v0.4.3

My app is still showing Jan 1, 1970.

It doesn’t matter.

Should be 0.4.4

Odd… asked Arduino to show me updates, and it does not show 0.4.4 as an option in the drop down list.

The RTC change is covered by Blynk’s Announcement at Blynk Library v0.4.4 is released [Arduino, Energia, Particle, MBED]

Needs to be done manually, follow the link in the Announcement.

Why is there a change in the process? Previous updates could be handled within the IDE’s library manager. Has it not been officially posted? Also, @Costas I am aware of the change noted, but it said nothing more than the RTC changed. It did not say that it would mess up my project by simply opening up the app on Android and going to edit mode (and making no changes). My point is, using 0.4.3 and my existing sketch should have still worked, but the app messed it up between iOS and Android devices. If I had devices deployed remotely, this sort of change would have been a cause for a big headache.

Every update has always said do it manually.

It’s documented on this site not to mix iOS and Android.

If you are using ESP’s and you want to deploy them to remote sites you can set them up to accept OTA updates.

@Costas, can you direct me as to where it states updates are all manual? …and mixing of apps is not recommended?

etc, etc

Fair enough.

However, let’s back up here for a second. The original context of the issue I am raising is I had no intent to update the sketch or library. I simply opened the updated Android app I had and it nulled out the V pin on itself and my iOS device. I understand why the app does this, but I was not expecting it (a change to the RTC pin). From a user perspective, my device should have continue to work fine given iOS and my sketch were not updated, but it broke. I get that Android and iOS cannot be the same, but then it should be clear that one should not use both apps at the same time.

Unfortunately you will have to update the sketch
Our iOS and Android apps will get aligned very soon.

Yup… Thx, did that and I am finally up and running again.

@deejayspinz in general you are right. However we do mistakes too. Android shouldn’t erase your pin, it should just hide it. So this is Android bug of 2.7.0 update. Sorry for inconveniences.

Its all good. Thanks for the quick responses. Still lovin Blynk…