SOLVED: Board shows offline


I have seen issues posted for this project before. It is OG or OpenGarage Door. The unit seems fairly nifty and worked out of the box with the token generated initially. In the web interface provided by the creator of the device, I then set wireless from dhcp to a static IP. After doing this, blynk can no longer see the chip and I get a red “1” icon at the tip part of the blynk app. “Generic Board wasn’t online yet” is the message I get when clicking on the icon.

Now, if I go in and do a factory reset on the device and register it in blynk and use the new token, once again blynk sees the chip. I then changed the IP from dhcp to static, and once again, I lost contact between the device and blynk server. So, I tried this a 3rd time, and it repeats. Factory reset, it works. Change from dhcp to static it breaks.

Any thoughts or guidance? Is it possible the token is related something like the network settings?


Can you share a link to the project and/or post the code you’re using (correctly formatted).

I assume that the code is using a version of Wi-Fi Manager, which allows you to connect to the ESP device and enter credentials? Does this allow you to specify which static IP address you want the device to use? - if so, what IP address are you specifying and have you checked that this IP address isn’t already in use on your network?


Hi Pete,

Thanks for responding. The developer has the project setup for the ESP to act as an AP initially and it displays available scanned SSIDs in range. From there, I pick my SSID and enter the password. At this point, everything works. It is not until I make the network change in the webUI being served off of the device that I see the issue:

His git is

I went to add some more screenshots of the AP mode where you enter you wireless info. I have this working from homeassistant using the address and my router config shows that this is the only device with that IP. I did try another IP, just to be super safe, and it as well had the same behavior. Factory reset, and all works again.


Here is the blynk screen:

And the AP screen when doing a factory reset:


I resolved the issue. All I did was set a DHCP registration for the MAC of the board. Looks like if you set it to static you must not get name service or something. Not sure how this works with blynk, but this did indeed solve it.

No clues as to what’s happening from the Github page as there’s no source code, just compiled binaries.
My guess is that there’s a bug in the code, so it might be worth raising it as an issue with the developer.


I think the issue is that my netgear is not expecting to service DNS unless it provides DHCP addresses possibly. This is the only thing I can figure. I will follow-up with the developer. He should provide a way to provide a DNS server, as it is probably not connecting to blynk via its IP addr.

Thanks for helping.