[SOLVED] Blynk with wemos d1 mini not working


I’ve searched for hours now and I can’t seem to find the solution for my problem.
I know wemos isn’t supported by blynk but I also know that many managed to install the esp8266 standalone sketch and worked from there.

I’ve uploaded that sketch to my wemos, connected with usb serial connector and I see nothing on the serial monitor.
on the app it says the device isn’t online.

Can anyone help me with this?
any suggestion as to what I can do?

I tried changing the baud rate and nothing…
the wemos worked with regular sketches but now I want it to work with blynk and it doesn’t.

any help will be appreciated.

Hello dear.
In order to get efficiently help we need more info like:
Arduino IDE version, ESP8266 Arduino core Version, Blynk library version, Your pc operating system.
Also the sketch that you work with
Start with these for the start…

Thanks and Best Regards,
Mike Kranidis

arduino IDE: 1.8.2
ESP8266 arduino core version: how do I get that information?
blynk library version: 0.4.8
OS: windows
and the sketch is the basic blynk example: ESP8266_standalone.
I only changed the token, ssid and password to match my own.

Thank you for the help.

It’s probably one of the MOST supported MCU’s.

What do you see in Serial Monitor?

1 Like

@Costas I see nothing! :frowning:
I tried different baud rates… tried changing some of the upload settings and still nothing… not even just symbols… just nothing.

Post your formatted sketch. I know you say it’s standard but we need to see just how “standard”.

  Download latest Blynk library here:

  Blynk is a platform with iOS and Android apps to control
  Arduino, Raspberry Pi and the likes over the Internet.
  You can easily build graphic interfaces for all your
  projects by simply dragging and dropping widgets.

    Downloads, docs, tutorials: http://www.blynk.cc
    Sketch generator:           http://examples.blynk.cc
    Blynk community:            http://community.blynk.cc
    Social networks:            http://www.fb.com/blynkapp

  Blynk library is licensed under MIT license
  This example code is in public domain.

  This example runs directly on ESP8266 chip.

  Note: This requires ESP8266 support package:

  Please be sure to select the right ESP8266 module
  in the Tools -> Board menu!

  Change WiFi ssid, pass, and Blynk auth token to run :)
  Feel free to apply it to any other example. It's simple!

/* Comment this out to disable prints and save space */
#define BLYNK_PRINT Serial

#include <ESP8266WiFi.h>
#include <BlynkSimpleEsp8266.h>

// You should get Auth Token in the Blynk App.
// Go to the Project Settings (nut icon).
char auth[] = "BLA BLA BLA";

// Your WiFi credentials.
// Set password to "" for open networks.
char ssid[] = "MY SSID";
char pass[] = "MY PASSWORD";

void setup()
  // Debug console

  Blynk.begin(auth, ssid, pass);

void loop()

the caps are my information that obviously I changed. :slight_smile:

Change 9600 to 115200 and set Serial Monitor to 115200 (9600 is just for slow Arduino’s not super fast ESP’s).

If you still see nothing try flashing the sketch again.

What com port are you connected to and does it appear in Device Manager?

Is it a D1 Mini or the slightly newer D1 Mini Pro (Pro has the antenna connector)?

Do you have several different USB cables you can try, some are rubbish and some only provide power (no tx / rx)?

I tried everything… but I’ll change it back to 115200.
I flashed the sketch 10 times already I think.
I see the COM port only if I connect the wemos through a us serial connector. through the USB I can’t see it… but again it worked with other sketches so that’s not the problem.
I’m not sure what is the new model but I have something that looks like this:

and I tried all the usb cables I have in the house… but again I can connect it through the usb serial connector…

also I’m pretty sure it’s not a genuine wemos because I don’t have the wemos logo on the silvery thing… near the antenna.

You have the old D1 Mini not the D1 Mini Pro.

The benefit of the WeMos is that with the USB port it is plug and play with Blynk. You shouldn’t need to be messing around with serial connectors.

Which version of Windows? Drivers should have installed automatically but try loading them again.

win7 and I installed them… do you have the link to install them again?
do I have to uninstall them before installing the new ones? and how?

Some fakes by their very nature don’t work. Has this particular ESP (i’ll not call it a WeMos) actually made any internet connections before you tried Blynk?

yup… managed to find my network, connected… I even switch the led on and off with http requests… :neutral_face:

Does your USB 2 TTL adaptor have the required 3.3V feed or did you blow the ESP with 5V from your Windows machine?

Is the ESP quite hot to touch?

I actually didn’t try to power it only through the TTL adapter…
I’m not sure I have 3.3V on the adapter… I think I have only 5V…

Should I power it through the adapter?

Certainly not if it doesn’t have 3.3V.

The genuine WeMos D1 Mini (not Pro) uses the CH340 chip and Windows driver is available at https://wiki.wemos.cc/downloads

It’s an executable so just run it but not sure it works with the fakes.

ok I installed the driver…

what should I try now?
running the ESP through the adapter, with 3.3v (which apparently I have… :slight_smile: )
still nothing…

Try flashing your sketch via the USB port (not adapter) if it now appears in Device Manager.

Failing that all I can do is give you a link to working with fake WeMos’ Reddit - Dive into anything