(SOLVED) Blynk only works when connected to pc


My arduino mega + ethernet shield only works when i upload the sketch and leave it attached to the pc.
If my pc is attached to the arduino i can control everthing with the app, but when i disconnect the pc everythin stops working.

anybody seen this before?


Hello. How do you power up your arduino?

with an 12v 1A power supply

Try to connect your mobile phone charger to USB port on your arduino when connecting to PC and try again.

It worked with an phone charger!


I have the same problem. The Sparkfun Thing Dev works fine with Blynk as long it is connected to pc (right after upload or when just reconnecting to pc). If using any other power source afterwards, eg the usb charger output, battery 5v on VIN etc, it does not seem to start up and no connection to Blynk app. If I only connect the usb to the pc, it works again even by only connecting to pc, No need to upload again.I am using the joystick controller merged to VIN1 to control two motors using an additional motor control hw.

Show us your code.

Use the template below:


Just replace CODE with your full sktech.

Please open a new thread for this… This one is 6+ months old and you clearly have a different issue as this post was resolved with external power. Please post your code as per @Jamin’s instructions in your new thread. Thank you.

Thanks, I have created a new issue here.