[Solved] Arduino Uno USB Serial - Device Offline in Blynk 2.0

i’m using arduino uno with cable via USB Serial and device is offline.

How to solve please? Tks

Hey there, try this:

  Download latest Blynk library here:
  Blynk is a platform with iOS and Android apps to control
  Arduino, Raspberry Pi and the likes over the Internet.
  You can easily build graphic interfaces for all your
  projects by simply dragging and dropping widgets.
    Downloads, docs, tutorials:
    Sketch generator: 
    Blynk community:  
    Follow us:        
  Blynk library is licensed under MIT license
  This example code is in public domain.
  =>          USB HOWTO:
  Feel free to apply it to any other example. It's simple!

/* Comment this out to disable prints and save space */
#define BLYNK_PRINT DebugSerial

/* Fill-in your Template ID (only if using Blynk.Cloud) */
//#define BLYNK_TEMPLATE_ID   "YourTemplateID"

// You could use a spare Hardware Serial on boards that have it (like Mega)
#include <SoftwareSerial.h>
SoftwareSerial DebugSerial(2, 3); // RX, TX

#include <BlynkSimpleStream.h>

// You should get Auth Token in the Blynk App.
// Go to the Project Settings (nut icon).
char auth[] = "YourAuthToken";

void setup()
  // Debug console

  // Blynk will work through Serial
  // Do not read or write this serial manually in your sketch
  Blynk.begin(Serial, auth);

void loop()

I tried this code that is example from the library, but it doesn’t work… the device is still offline. (I replace char auth[] and BLYNK_TEMPLATE_ID with my information and nothing.)

Thank you for your help @John93

Your script is trying to connect to, which is the Legacy server.
You could try editIng the script and changing the server to and maybe port 8080 but not sure if USB connection is supported in Blynk IoT. Normally the Template ID is required and I don’t think the script has been updated to accommodate this.


1 Like

that’s it! @PeteKnight

I edited the blynk-ser.bat file by changing the line set to set and it is now connected. Thank you @PeteKnight

Excellent! Wasn’t sure that it would work, but glad it did.


1 Like