[SOLVED] Arduino mega with Ethernet shield

Hi there,
I have a Problem with my arduino configuration. It does not work with the blynk App. I tried different ways to built up Communication. My Router (speedport w921v) has the arduino in its list with Mac DE ED BA FE FE ED and ip I also copied the right auth into my arduino code.

Must I route a Public Port to a Client Port (maybe Port 80) ?

Configuration :
Arduino mega
Arduino Ethernet shield
Speedport w921v

Thanks for a quick answer and sorry for my bad english…

Hey alpha,
What version of the Arduino Ethernet shield u have?

The “new” Arduino shield 2 with its W5500 chip is not supportet yet :frowning:
An alternative is to connect it without the shield until they implement it.
Here a link to a little tutorial from them : http://docs.blynk.cc/#hardware-set-ups-arduino-over-usb-no-shield

Greedings Philipp

Hi Philipp, thanks for your answer.
I use an Ethernet Shield with 5100 Chip. I also use latest blynk examples. I think its a Router fail but don’t know what is wrong because of no network experience. In other examples i read somerhing about port unlock in the router. The Port 8442 is used in the blynk examples.

Thanks for help.

Port has nothing to do with it because it’s an outgoing connection. I assume you’re using the cloud server? E.g. cloud.blynk.cc

That should just work fine, unless you have a really REALLY strict firewall policy on your router or your ISP (like my mobile one …) is blocking SSL traffic on ports other than 443.

What you may be able to do is try and setup a local Blynk Server on one of your computers and try to connect to that. That way you can eliminate it’s a hardware failure or something like that.

Another thing to try is to setup a manual IP address for your Arduino. Some routers/modems don’t like simple Ethernet things.

Did you check our troubleshooting guide? http://docs.blynk.cc/#troubleshooting-connection

Hello, I did it all - manual IP adress etc. Also a ping test is ok, but only without blynk.run:

#define BLYNK_PRINT Serial    // Comment this out to disable prints and save space
#include <SPI.h>
#include <Ethernet.h>
#include <BlynkSimpleEthernet.h>

// You should get Auth Token in the Blynk App.
// Go to the Project Settings (nut icon).
char auth[] = "038edfc771e2489c9e089a53c3757510";

IPAddress server_ip (10, 0, 0, 10);

// Mac address should be different for each device in your LAN
byte arduino_mac[] = {0xDE, 0xAD, 0xBE, 0xEF, 0xFE, 0xED };
IPAddress arduino_ip (192,168,2,211);
IPAddress dns_ip     (192,168,2,1);
IPAddress gateway_ip (192,168,2,1);
IPAddress subnet_mask(255, 255, 255,0);

void setup()
  Blynk.begin(auth,"cloud.blynk.cc",8442, arduino_ip, dns_ip, gateway_ip, subnet_mask, arduino_mac);
  // Or like this:
  //Blynk.begin(auth, "cloud.blynk.cc", 8442, arduino_ip, dns_ip, gateway_ip, subnet_mask, arduino_mac);

void loop()


Without blynk.run :

serial monitor :

[0] Blynk v0.3.1
[0] Using static IP
[1300] My IP:

ping test is ok.
arduino is listed in my router

With integrated Blynk.run :

[0] Blynk v0.3.1
[0] Using static IP
[1300] My IP:
[5001] Connecting to cloud.blynk.cc:8442

Ping test requests with time overflow.
arduino is not listed in my router

Thanks for help!

Are you ok with having IP ?

NO I’m not! Blut what is the reason? In my scetch its the IP and I also see this IP in my router.


What Ethernet shield do you use?

Is it possible that the wrong IP is a Hardware failure (Ethernet shield) ? I read something abut it in an other forum.

Yes, tell me please what shield do you use. Maybe we do not support it.

My shield Workshop with a 5100 Chip but its not Original arduino.

Are you sure it 5100?

Here is same issue with 5500 and 5500 not yes supported.

I can not really read the print on the chip but the shield is more than ohne year old.

Tomorrow I order an original new shield . Maybe IT works better…:rage:

You could also order a ENC28J60. Its really simple to hook up and works very well with Blynk and the UIP library. And it’s dead cheap…

Hey there, it runs! I ordered a arduino shield (original with MAC etc) and now the scetches run ! I am very happy about it after searching hundreds of hours for a mistake in the scetch or in my router its now all right.
Thanks to the community for help!!!

1 Like

I have just started using Blynks and was having the same issues as above, with Arduino Mega and Sainsmart Ethernet shield, i.e. would not get DHCP IP address and static IP showing etc, I solved mine by removing the micro SD card that was sitting in the card reader!!! I have no idea why this made a difference, but glad it did as it was very frustrating.

@PWFK, This is a well-known issue described on official Arduino Ethernet shield documentation…