[SOLVED] Arduino Mega USB Serial connection troubles

Hi! Hope, you can advice or hint me some idea.
I haveMega2560 board, tried to deploy SerialUSB sample sketch but when connect to my phone and tried to run the project, got msg like: “Your Arduino Mega is not in network”

Here is My steps:

  1. Dnload and install Blynk app from GooglePlay,
  2. Created new account
  3. Created new project, generated token, (and sent by email).
  4. Dnloaded Library and installed it to Arduino IDE.
  5. Dnloaded sample sketch (this one: https://github.com/blynkkk/blynk-library/blob/master/examples/BoardsAndShields/Arduino_Serial_USB/Arduino_Serial_USB.ino)
  6. Connected Mega via USB to PC, compiled and deployed sketch to board. (Token copied from that Email)
  7. Reconnected USB cable from PC to Phone
  8. Pressed Reset btn on the board.
  9. Tried to Run project But got that message.

What could be the problem? Probably some phone software can interfire?
Here are my soft and hardware details:

PC OS: Ubuntu linux 14.04
Arduino IDE: 1.6.4.
Board: Arduino Mega 2560
Phone: Lenovo s660 (Android 4.2.2)

P.S.: Probably stupid question, but…
Is that necessary to run this scripts: $/Documents/Arduino/libraries/Blynk/scripts ? In case when you use IDE? (I didn’t do that)

@dimmask85 you need to open the gateway on your linux machine.

In the zip you downloaded for Blynk there is directory called scripts. I don’t do much linux stuff other than a bit of the Pi derivative. The bat files opens the exe on Windows and the blynk-ser.h is what you need for linux. Fairly straightforward script file to connect your linux machine to the Blynk server and open your USB port for the Mega to see the server.

1 Like

Many thanks, Costas, will try now

Thanks a lot again. That really helps! :wink: