[SOLVED] App's Pin-history Data dialog won't raise the Android keyboard

In the Pin-History Data Example- and Console dialogs, you can paste into the token and pin# boxes but you can’t type into them because the keyboard doesn’t raise. If you switch away from Blynk temporarily with the recent apps button to copy your next entry to the clipboard, when you return to Blynk, you return to the History Graph description. Clicking HTTP API sends you back to the Pin-History dialog but you’ve lost any previous entry you have to start over. As a result, there is no way to make more than one entry on that dialog.

Blynk 2.14.4
Android 6.0.1

What or where is a “Pin-History Data Example”? Are you referring to ANY data entry option in a widget or only this specific “example”?

I have multiple Android devices with varying versions and haven’t seen any text entry issues, but I usually run stock keyboards… are you running a specific keyboard app?

  • With the app paused, touch a History Graph widget. It’s settings screen opens.
  • In the History Graph widget’s settings screen, touch the “i” icoon on the right end of the title bar. A screen describing the history graph slides up.
  • The next-to-bottom line says “You can also get pin data via HTTP API.”, where the last two words are a link. Touch the link.
  • The Pin History Data dialog appears. it is pre-filled in with sample data, specifically, an Auth Code and a Pin Number. It is those two fields I want to use.

I have SwiftKey and Hacker’s keyboards; I get the same result with either of them and with the Google keyboard.

Ah, I see… you are referring to the Blynk HTTP RESTful API - http://docs.blynkapi.apiary.io/#

I honestly don’t use that myself, but I suspect, based on the existing “sample” auth not being close to my project’s actual auth, what you are seeing in the app is more a representation of the web page.

I believe you you really need to go to the actual web site in order to set it it up. @Dmitriy am I correct, or is there an actual data entry issue here?

@JRobert this is just demo site. It is not supposed to be “real” URL. And has the fake token, so you have to put there your own…

1 Like

Got it. And it looked so real… :slight_smile: