Simple Getting Started (Connecting Wemos D1 to Blynk)

Hi All,

I have a WEMOS D1 board and have successfully loaded the ESP_8266 Standalone Script using Arduino IDE 1.8.1.

Serial monitor shows good connection to my wifi and connection to Blynk with 1ms ping.

However, my iPhone shows he device as being offline.

Have reloaded the code, reset the device. Logged in and out of the iPhone app to no avail.

Probably a simple error and would appreciate some guidance.

Use the PushData example to confirm connection.

Thanks. Seems the Pushdata example requires and ethernet connection which my WeMos does not have. Is there a WIFI version or should I cut an paste to make it work?

@Gunner just linked you to the example generator

Most grateful. Will give that a try now.

Have loaded the Sketch with the following result:

Connecting to SPGJAG
[3247] Connected to WiFi
[3247] IP:
___ __ __
/ _ )/ /_ _____ / /__
/ _ / / // / _ / '/
//_, /////_
__/ v0.4.6 on Arduino

[5001] Connecting to
[5490] Ready (ping: 0ms).

The device has obtained a viable IP address and I can ping it on my LAN but I believe it should be doing more??

Have also tried some of the troubleshooting tips and I cannot telnet into I have a good internet connection…

My error… Have removed the : from the telnet address and get a “connected” response from a terminal hence no issue with my connection to the server.

However, my iPhone is still showing the device as being off-line…

Have you tried the app part of the example? You just need to add a single widget to the specifed Virtual pin and you will see the hardware uptime counting every second. You won’t see anything in the serial monitor.

Problem Solved:

I had 2 boards loaded. An Arduino as a “primary” board and a Wemos D1 as an additional board. I was not able to delete the “primary” board from my iPhone app so changed it to Wemos, resent an Auth Code and now it works.

1 Like