BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

Sim800L not getting connected to blynk server

Hi ,
I am using sim800l gsm module with arduino uno and sim800 powered from arduino using diode from 5v out of arduino.

Device getting connected to network & entering to gprs mode using apn sucessfully.(Gsm led blinking faster).

But after that this msg keep on comming in serialout

Connecting to blynk-cloud.com:80
Connecting to blynk-cloud.com:80
Etc…

Am using latest library of blynk and default example code with only few changes i made in code is

gsm baud changed to 9600
Access key
APN

Somebody please helpme in this

SIM800L Specification

  • Supply voltage: 3.8V - 4.2V
  • Recommended supply voltage: 4V
  • Power consumption:
    • sleep mode < 2.0mA
    • idle mode < 7.0mA
    • GSM transmission (avg): 350 mA
    • GSM transmission (peek): 2000mA

You might want to re-think that, as the Uno’s voltage regulator can’t provide 2A. It may provide enough for some SIM800L functionality, and it also die trying.

Also, you might want to force Blynk to use either port 8080 instead of port 80. How you do this will depend on whether you are using Blynk.begin or Blynk.config in your sketch.

Pete.

Thanks mr.

Could you please explain, how to do this.

Yes, if you tell me whether you’re using Blynk.begin or Blynk.config

Pete.

Yes… i am using that sample code from blynk server… no change in that

And does that sample code have a line in void setup that says Blynk.begin(Auth); ?

Pete.

I am using same as this code

https://examples.blynk.cc/?board=Arduino%20Uno&shield=SimCOM%20SIM800&example=Widgets%2FTerminal&auth=IWf9G8y340vjw9Z-KdmVxBfoXjq18uoj

Change this line:

Blynk.begin(auth, modem, apn, user, pass);

to this:

Blynk.begin(auth, modem, apn, user, pass, "blynk-cloud.com", 8080);

Pete.

thank you very much…
i solved problem… not code issue… power supply dont have sufficient amps… so sim800 restarting… solved with a capacitor

I told you that in post #2

Pete.