Setup local blynk server on RPi 3

In first time i want say about my english … he bad)
But i hope you understand me.

I use blynk server with rpi and docker.

I use cmd to run srv:
run --name blynk-server -p 8080:8080 -p 9443:9443 -p 80:80 blynk

But terminal write me error:
/usr/local/bin/ line 48: java: command not found

I have last version java. I dont understand why line in is not working :
java -jar /blynk/server.jar -data…

Please help me :frowning:

I don’t use Docker (I tried it and didn’t like it) but that start command is very different from what the documentation says:


Hello. Thank you for answer.
Ok, if dont use docker, server start and i can connect from mobile app Blynk, but i cant use web interface . Link myLocalIP:9443/admin dont working :frowning:
This in rpi

I try install blynk server on mobile, in linux console. Server on mobile working!
Maybe need on rpi open ports? But i dont know how do it.

If you’re not using Docker and your device is connected to the same network as the Blynk server then you don’t need to open any ports.
What browser are you using, and what do you see when you try to access the admin portal?
Are you using https or http when you do this?


I use static ip from my internet provider.
You can see this page, its my server.
I use chrome on mobile, on home PCs and standart browser chronium on RPi . All browsers show one page with code:

My mobile device is connected now with this ip and port 9443. But admin portal not working

Your very brave, posting your public static IP on a public forum!

You need to use https when connecting to the admin portal.
Are you using and port 9443 in the custom settings of the Blynk app, and is this working?


Oh… I dont think about it.))

Yes, i use ip 95.52.. and port 9443 in app. Its working.

I tried use address https://ip:9443/admin and again dont working

I fix it)

Thank you for try help me!
I fixed problem.
Web portal not working because i dont write line in
Early writed address is (localhost) and he not worked from local machine

But my question about docker is actual :))

You’re best using this entry…


at least for testing.


1 Like

Thank you. :slight_smile: