Setting Up Local Blynk Server on Win7 - Guidance Please

Hi all.
I have looked at relevant posts but am still having difficulty configuring the Blynk server - getting frustrated to the point of, well, giving up!

I have created and installed a bat file in accordance with GitHub guidance (start-blynk.bat). I have installed latest version of the Java sdk and Java runtime environment and downloaded the blynk server .rar file version 0.15.3. But, the decompressed .rar folder doesn’t appear to have Windows executable files? So it is unclear how to complete the installation and configure the Blynk server. I must have overlooked something - probably trivial.
In anticipation - Many thanks.

Hello. Did you see this? -

Yes, I did look up several links before posting on the Forum. Used the GitHub resource info to create Windows bat file ‘Enabling Server auto-restart’, but I am unsure where to locate the file ‘java -jar server-0.15.3.jar -dataFolder /path’ referenced in the ‘Quick Local Server setup’ section. Also, where do I copy the downloaded compressed .rar file. This is a little unclear.

We don’t have any .rar. All you have to do is just to run command from command line:

java -jar server-0.15.3.jar -dataFolder /path

That’s it. Nothing more.

Unable to try suggestion now Dmitriy. Will follow up tomorrow morning and report back. many thanks for your reply.

Get the following error message at command line:
‘Unable to access jarfile server 0.15.3.jar’

In the issued command at the command prompt:
java -jar server-0.15.3.jar -dataFolder /path

Where is the server located by default on Windows, and therefore the path to it?
I havent installed a Java ‘server’. Please excuse the questions, I am a novice programmer.



I ended up reading through the issue so the first line (saying I hadn’t) seemed out of place and it wont let me do a markdown strikethrough to show it was there but changed. Anyway… I noticed one part i can answer easily for you, and the rest should get you going i hope. if not go back to Github and ignore the simple start and go for the not so simple but more comprehensive an likely to work one.

Actually; those instructions aren’t really helpful unless you’d already done what i suggest… and are a java developer. If this Doesn’t work, there’s a docker container which does work and doesn’t need you to know java so reply if needs be and I’ll put instructions for that up here or you (unless you know docker in which case it’s docker pull mpherg/blynk-server)

To answer a question you kind of asked: Java doesn’t produce .exe files, you run the output either through a command prompt as you already have or create a a new shortcut and put that same command in he box where you would put the location the shortcut to point to and that should work

If you’re interested why, the first word java is actually shorthand for the java.exe file that you installed when you installed the SDK, This is the executable you’re running, and it’s called a virtual machine or JVM, which lets that java code in the .jar file run on windows or mac or linux, hey each have an individual JVM so developers can write one program and run it wherever.

This means that everything after that are command switches and arguments being passed to the java executable; so java -jar something.jar would be telling Java to expect a .jar file, and the name of that file as well as a path to it if you’re not in the folder where that .jar file is.

So if you were to create a shortcut for the start menu, you would have to add some additional information.

Actually looking at the code, i’d suggest that you do the following:

(note: I haven’t used a windows computer for longer than about 25 minutes a about 5 years but i also did do windows desktop support as a job for over 5, so lets see if that balances out!)

  • make a folder in your home directory called Blynk

  • inside that one called data

  • then copy the server-0.15.3.jar file into the blynk folder

  • then try this exact command,
    –Don’t forget that the file and folder names are case sensitive and the %blahblah% bits will be replaced by windows when it runs the command with the location of the currently logged in user’s home folder

    java -jar “%UserProfile%/Blynk/server-0.15.3.jar” -dataFolder “%UserProfile%/Blynk/data”

  • if it works from run copy and paste it into a new shortcut on your desktop and either leave it there or drag it to somewhere else like the start menu if you’d prefer that

I think -dataFolder must be for the location where it should look for the your data used to populae the server, your opions and dashboards etc, the only reference i could fine online was here on github which seems to be the actual java file used to make it work it looks like a webservice thing so i guess thats what it is, this las paragraph doesn’t need to an action, it was just FYI

1 Like

Hi Jamie
I am running the Java Server (successfully, as indicated in Windows Command Console) on my desktop PC behind a ZyXEL Wireless router. I understand that I need to apply a NAT rule for the local Blynk server hosted on this PC. Can you advise what port / port range I need to assign.
Many thanks

8442 for non-SSL hardware and 8443 for the App if I remember correctly, TCP only :slight_smile:

1 Like

Thanks for your response. I will now set the start/end port range to include these Port ID’s.

Hi all
I think I am getting there albeit slowly. But now getting message ‘User is not Registered’ at the Blynk phone app interface when attempting to access the Java server in ‘Custom’ mode, which for me is (on port 8443 - app default). I have interrogated the Local Blynk Server log and it reports an ‘unregistered’ user ‘’, (my mobile phone IP via DHCP). So, there is clear connectivity to the server. There doesn’t appear to be a facility to create users in the ‘’ file. I cannot launch the Admin UI web interface at present if this is the mode to manage users.
In anticipation. Many thanks.

@Hafod just register user within Blynk app. :slight_smile:

Hi Dmitriy. Thanks for your reply. What is, if any, the difference between ‘creating’ a new user and ‘registering’ a new user as suggested. I tried the former which resulted in me getting the ‘unregistered user message’. So, your suggestion is unclear. I have registered as a ‘Blynk’ user with a separate account and successfully created projects via cloud server, but was attempting to create a ‘new account’ (‘Custom’ app setting) to access my local server using a different E-Mail address for Local server based projects. I cant see another way of doing it within the app? Perhaps I am confused here.

Cloud server not connected with local server in any way. That’s the point of local server. It’s fully yours. So in order to login you have to register/create new user in same way you did for Blynk Cloud server.

OK. I see that. My earlier post shows that the error message I received on the app and in the server log shows that the local Blynk server is rejecting the user registration/creation for some reason initiated by means of the app. The response message ‘unregistered user’ in response to the creation request suggests the server is attempting to authenticate stored users - hence my last post. Re your post, I am creating user the same way, except ‘Custom’ instead of ‘Blynk’ in the setting process. Any suggestions on this Dmitriy?

Those error shows that you are trying to log in instead of register user. Please check both apps and server are latest version and try again.

1 Like

Hi Dmitriy. Yes, re-installed Blynk app and can now create new users on the Blynk server. Thank you again. I am not getting E-Mailed tokens generated by the yet but I suspect this is a result of the need to look at port forwarding using TCP. Lichsignaal, in his post has suggested TCP ports 8442 and 8443 to do this. The server logs are very helpful in helping to ascertain what is going on in the server but I still can’t launch the web based admin UI. Any ideas on this one?

How do you try to reach it?

Re: E-Mailed tokens. This problem is now resolved - was a security issue within my E Mail UI settings.
Re: Web Management UI. Issue with the SSL security certificate and Firefox. Added an exception which resolved this problem. The UI has many useful features to manage local Blynk accounts, although the server logs are useful resources. Thanks for your help.

However, whilst I now have an operational Local Server and can connect to it using Blynk hosted on my mobile phone and generate a project (simple at moment) - with no errors, I can’t get the Blynk app (on my mobile) to show data on a guage widget. (I am measuring T and H using a DHT22 sensor connected to an ESP8266) I think I am nearly there but should I continue with this post and add the technical detail or start a new post?

Did you point your hardware to own server?