BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

Server.property location?

I have made changes to my local server.properties file in the server configuration tab. Where is the server.properties file saved so I can check if these changes were made?

If you make changes via the console then they aren’t actually saved.
You need to open and edit the file.
It normally lives in the same location as your server.jar file, but you can specify a different location in your server start-up command.

More info here…

Pete.

Hi Pete, that’s my issue. I don’t have that file in the directory where my jar is.

So what command do you use to launch your server?
Are you running this on Windows or Unix ?

Pete.

Windows PowerShell.

Besides the jar file, there is the admin file and 4 directories; backup, clone, deleted and static.

Forgot to mention the command, here is: java -jar BlynkServer/server-0.41.14-java8.jar -dataFolder /projects/java/blynk/blynkdata

For more flexibility you can extend server with more options by creating server.properties file in same folder as server.jar . Example could be found here.

If the file isn’t there already then you need to create it.

Pete.

Perfect, I’ll do that and come back to you soon. Thanks Pete.

Alex.

So I created the server.properties file in the same directory of the .jar file. Impact?

  1. I still get a “No secure” connection.
  2. The parameters in the server.properties can be seen in the server window now, but although it does says that it is successfully saving changes, it is not true, the changes are not saved in the server.properties file.
  3. I still get contradictory errors like: the contact.email is missing, which is not true, I did enter the email data in the server.properties file.

I’m not sure that having a custom server.properties file will change that.

I told you that already…

Did you also create a mail.properties file?

Pete.

Pete: I’m not sure that having a custom server.properties file will change that.
Alex: Writing in the path where to find the local certificate…

Pete: I told you already…
Alex: I most likely misunderstand the utility of the “save” function in the Config menu in the created server UI. Does it save anything, where?

Pete: Did you create a mail.property file?
Alex: Did I have to? Doesn’t the jar file creates all the required files? What other files I need to create?

I have seen YouTube videos that people used the Java -jar… file to create the server and all goes smoothly, and since is not in the local server creation instructions, I did not create other files by myself.

Can you please provide me with the template for the mail.property, thanks.

I don’t use certificates on my local server, or HTTPS connections from my devices (NodeMCU’s) to the Blynk server, but my assumption that the purpose of the certificates is to allow SSL connection between the devices and the server (using the BlynkSimpleEsp8266_SSL.h library for example) and not between the browser used for accessing the server admin portal.

The only mention in the docs about how to overcome the browser warnings is if you are using Chrome…

Turn off chrome https warning on localhost

  • Paste in chrome
  chrome://flags/#allow-insecure-localhost
  • You should see highlighted text saying: “Allow invalid certificates for resources loaded from localhost”. Click enable.

This is why I said…

NO

It’s all in the docs on the GitHub site…

Pete.

Thank you Pete, I’m actually following the documentation where we are told to install our own certificate, but unfortunately the jar coding file does not enable this. And I think this is the reason why I cannot access the server from my iPad, which makes the use of Blynk not feasible.

I’ll park the subject for the moment and thank you for all your help.

Well, as I’ve said before, I don’t use certificates on my local server and I can access the admin console via my iPad.
I think you’re looking in the wrong place for the solution, but how you choose to proceed is up to you.

Pete.

Everything is possible, but the aftermath is that I’m able to access the server (in insecure mode) in my laptop, but I cannot connect with the server via my iPad. So I cannot create any application to interact with my Arduinos devices.

So your real issue is the app connection to your local server rather than your access to the server console?
As you’re using windows to host your server then maybe check that your firewall isn’t blocking port 9443

Also, make sure that you are connected to EXACTLY the same WiFi network, and ensure that one isn’t connecting to a 5G network and the other to 2.4G. It shouldn’t make a difference unless they are on separate vLANs, but it’s possible.

There is another option, which is to use ZeroTier, which is a very nice option (and free).

Pete.

Right, I believe I said this from the very beginning that I could access the console from the laptop URL, but not from the iPad, and that I suspected the insecure connection as the culprit. That’s why I was working hard in creating my own certificate. Sorry if I misled you.

My laptop is connected with ethernet, and my iPad could be most of the time on the 2.4GHz WiFi. But this should not matter as they are both connected to the same switch as internet is concerned, so they are both a local connection.

I’ll check ZeroTier…learning a new application is always a gain :slight_smile:

The problem for me is that you started by focussing on certificates and the server.properties file, instead of describing the symptoms and then saying what you thought the cause was.

Even this reads that your symptom is that you cant access the server console from your iPad, which is different to not being able to connect the Blynk app running on the iPad to your local server.

Had you stated that from the beginning, and said that you thought it was because of certificates then I’d immediately have steered you away from that idea, saving us both a lot of wasted effort.

Pete.

Actually, I cant not even get beyond setting up the Blynk green UI app in the iPad…

No wasted effort in my side, I have learned a few things on the way, thanks!

“SOLVED”

I had to make a new rule in my Windows Defender, and I’m in :crazy_face: