BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

Server does not open port 8441


#1

Hello,

I am a happy blynk user since about two years now. Lately I came up with a new project and experienced some issues so I thought to update the Blynk server from 0.30 to the latest version 0.41. Then the devices could not connect to the server anymore (app could!) and problems began…

Long story short, I found out that the last working server version is 32.2. According to the changelog, the old hardware server on port 8442 was removed in version 0.33 so this seems to be the root of my problem.
I am running blynk server (java 8 version) on a RPi 3 and can see that the Ports 8441-8443 are nether initialized during server startup log nor are they opened on raspbian.
I thought of a bug first but I’m sure I’m not the first person experiencing this problem after so many releases in the meantime.

So, here’s my startup log:
23:38:38.901 INFO - Using data dir ‘/home/username/Blynk’
23:38:41.269 INFO - Region : local. Host : sub.domain.tld .
23:38:43.105 INFO - Initializing gmail smtp mail transport. Username : blynk@sub.domain.tld. SMTP host : smtp.strato.de:587
23:38:43.423 INFO - Reports : 0
23:38:43.434 INFO - Didn’t find Let’s Encrypt certificates.
23:38:43.434 INFO - Automatic certificate generation is turned ON.
23:38:46.075 INFO - HTTP API and WebSockets server listening at 8081 port.
23:38:46.080 INFO - HTTPS API, WebSockets and Admin page server listening at 9443 port.
23:38:46.083 INFO - Mqtt hardware server listening at 8440 port.
23:43:03.373 INFO - name@domain.tld Blynk-app (android-22700) joined.

I would be grateful if someone could help me solvong this problem, especially in respect of the removal of old Hardwareserver and why the new one seems not to start…

Kind regards


#2

Well, you are not a newb so you should have seen similar “Local Server upgrade issues” around the forum :stuck_out_tongue_winking_eye:

Blynk%20-%20RE-SEAR-CH

New versions of Blynk Server (and Cloud for that matter) use port 9443 in the App and 8080 (TCP) 9443 (SSL) on the hardware device

Don’t forget to update your Library as well before flashing… all Blynk components (App, Server & Library) need to be kept keep in version sync with each other over time.

The ports as per the various Announcements…

And if you are using SSL… there may be some other script changes needed… here is another very recent post about such…


#3

Thank you for your super fast response!

Seems like I did search in the wrong places (and of course not good enoigh) because I misinterpreted the Problem.

I changed the Port and am able to connect with my device, thank you alot for ypur help!

Still, I am curious about one thing:

New versions of Blynk Server (and Cloud for that matter) use port 9443 in the App and 8080 (TCP) 9443 (SSL) on the hardware device

Assuming this is right (this is obvious as these ports are also statet in the server log), I see two differences in latest BlynkConfig.h file on line 21 and 22. BLYNK_DEFAULT_PORT is set to 80. I assume this is because the server parameter force.port.80.for.redirect defaults to true.
More interesting, BLYNK_DEFAULT_PORT_SSL defaults to 8441 which is obviously not valid.

Kind regards


#4

I admit a bit of confusion on all the port stuff despite being a PC tech for years :stuck_out_tongue: But I think port 80 is still validly used in the Local server somehow…

Perhaps you are looking at older files that haven’t been changed in some repository? :thinking:

Anyhow, you are welcome… considering this topic solved :smiley: