Running Blynk everywhere (even in Linux, Mac and Windows)

Hi guys,

from a Facebook post I see that you are trying to control every hardware there is (including PCs, with nodeJs).

So, would you like the idea of people running your app everywhere too?
With this hack, one could run the Blynk app in Windows, Linux and MacOs.

I was able to load and run Blynk in my Ubuntu 14.04 desktop, running it in Chrome (see screenshot below). However it does not connect to the blynk server:

More details here:

PS: I do not know how persistance for the projects would work, nor I claim that it will be easy to fix the blynk code to run there.

1 Like

Where are able to get the app to connect?

I tried Blynk with Archon about a month ago and I could not connect to cloud.Blynk or a self hosted server.

hey there, sorry for not stating so in the original post. I have made a modification now.
And no, I could not connect the app to the blynk server, that is why I proposed the idea of fixing the Android code in Java to the developers of the app - if they have the time and the interest and the priority of course.
I don’t even know if it is even possible to just fix the code in the app, for that matter.
All I know is that some apps can run in archon, and maybe Blynk can too.

@gusgonnet @priorguy

Could you please tell me what error do you get when trying to connect to local server? (“logs/blynk.log”)

Hi @Dmitriy, I can’t tell since I did not run a local server, maybe @priorguy would know?

Ok, I’ll investigate when will have free time.

1 Like

I manage to run blynk by using ARC Welder (Chrome Extention), but yet it could not connect to the server, just showing the 3 dots revolving.

I tried to scan barcode, although the webcam is on (there is a led in my laptop showing whenever an application accessing webcam), but it’s not showing any picture.

@Dmitriy: please help if you have time. Thanks

1 Like

The log files show, with my local server, not even an attempt is being made to connect to the server. I’m running ARC Welder on MacBook, so we tried on three different platforms, therefor the problem must be in ARC Welder. It may be more prudent to search for support on the ARC Welder side of things. I’m thinking it has something to do with either SSL or networking in general from the ARC Welder side.

@Dmitriy : is it possible to run the AppServer without SSL? Just for testing purpose of course :wink:

In early days - yes. But not anymore.

Can’t say anything. Probably extensions are not allowed to use non standard ports. This is just my suggestion.

No, it’s not that either. I mapped 443 to 8443 and tried from outside, doesn’t work either. I’m guessing it’s just not possible using ARC Welder.

You can always go Droid4X, but it’s a heavy package to be running for one App.

Today when I open Google Extensions in developer mode, I saw an error message:

Blynk 2.0.3
Details Launch Reload (Ctrl+R)
ID: pgkefknkiejbhpdhpofcioomkknpombg
Loaded from:\cc.blynk.apk_export_YcTAn
Inspect views: app_main.html app_main.html (iframe)_modules/mfaihdlpglflfgpfjcifdjdjcckigekc/gen_index.min.html
There were warnings when trying to install this extension:
Unrecognized manifest key ‘arc_metadata’.

What page are you on?

tested today : window 10, latest version of bluestack with latest version of blynk, run well :smiley:

Here is a thread about chrome compatibility using twerk :

I have opened a stackoverflow issue there (recommended channel from arc welder), but they need someone from blynk team

I don’t find it too heavy… I now have two instances running all the time (one on Cloud Server, one on Local server). Only 20-40MB each (my anti-malware itself takes over 150MB) and the one running an active app 24/7 only draws between 0.5-2% CPU (old Q6600 with 4GB RAM).